Outlook 2007 Service Pack 2

Ask your questions and get help with Zimbra's Outlook Connector.
snissen
Posts: 23
Joined: Fri Sep 12, 2014 11:13 pm

Outlook 2007 Service Pack 2

Postby snissen » Fri Apr 17, 2009 12:42 am

On April 28, 2009, Microsoft is expected to release Service Pack 2 for Office 2007, including Outlook 2007 SP2. (Pre-release versions of SP2 have been available since last fall.) Here's the most detailed information I've seen: Office 2007 Service Pack coming in April - Office Watch



So my question is: Has anyone tested Outlook 2007 SP2 compatibility with the Zimbra Connector? If so, what versions of the Zimbra Connector, and with what results?
As soon as I have a chance to test anything, I'll post my results in this thread.


Rich Graves
Outstanding Member
Outstanding Member
Posts: 687
Joined: Fri Sep 12, 2014 10:24 pm

Outlook 2007 Service Pack 2

Postby Rich Graves » Fri Apr 24, 2009 8:23 pm

Obviously they haven't tested the final, but Zimbrans have been recommending the pre-SP2 rollup since March 7th. Zimbra wiki: Outlook 2007 improvements in the February 2009 cumulative update.

That's how I found out that office 2007 sp2 was coming.
6510RWilliams
Posts: 7
Joined: Sat Sep 13, 2014 12:08 am

Outlook 2007 Service Pack 2

Postby 6510RWilliams » Tue Apr 28, 2009 12:56 pm

We're using version 5.0.15_GA_2850_5.0.2931.15 of the connector, and SP2 seems to break it. After installing Office 2007 SP2 and rebooting the machine, I keep getting errors about not being able to open the Zimbra.zdb file, and immediately shuts down Outlook upon clicking OK. I had to do a System Restore to go back to SP1, and now everything is working fine again.
snissen
Posts: 23
Joined: Fri Sep 12, 2014 11:13 pm

Outlook 2007 Service Pack 2

Postby snissen » Wed Apr 29, 2009 1:33 am

I tested the "February 2009 cumulative update" for Outlook 2007 that Rich Graves mentioned. (These are documented as the same as SP2.) They worked fine with ZCS Connector versions 5.0.10, 5.0.11, and 5.0.15, on several PCs.
Today, I started testing Office 2007 Service Pack 2 with ZCS Connector 5.0.15 on several PCs, and it's working fine as well. I'm now much more confident that there will be few problems.
Before we roll out Office 2007 SP2, we may consider some basic precautions:

- make sure everyone is using the latest ZCS Connector;

- make sure the mail data files are in good shape (maybe compacted too);

- run chkdsk.
Has Zimbra ever created a mail data file checker similar to Microsoft's ScanOST.exe/ScanPST.exe? Sande
MisuVir
Posts: 13
Joined: Fri Sep 12, 2014 11:11 pm

Outlook 2007 Service Pack 2

Postby MisuVir » Wed Apr 29, 2009 2:09 am

I haven't had any major problems with Microsoft Office 2007 Service Pack 2. The only issue I've had is as described in http://www.zimbra.com/forums/zimbra-connector-outlook/28318-sent-items-unknown.html and [url=Bug 37146 – Sender shows as "unknown" after applying Outlook 2007 SP2 Hotfix[/url].
iway
Outstanding Member
Outstanding Member
Posts: 425
Joined: Fri Sep 12, 2014 11:31 pm

Outlook 2007 Service Pack 2

Postby iway » Wed Apr 29, 2009 9:32 am

Yes, this: Bug 37146 – Sender shows as "unknown" after applying Outlook 2007 SP2 Hotfix is a huge problem for our users. The From field is showing Unknown now, not really good.
fsiegel
Zimbra Alumni
Zimbra Alumni
Posts: 1334
Joined: Fri Sep 12, 2014 10:16 pm

Outlook 2007 Service Pack 2

Postby fsiegel » Wed Apr 29, 2009 7:37 pm

Bug 37146 (Unknown showing as the From address in Sent Items) has been fixed. It will be in 5.0.17
ewilen
Elite member
Elite member
Posts: 1429
Joined: Fri Sep 12, 2014 11:34 pm

Outlook 2007 Service Pack 2

Postby ewilen » Wed Apr 29, 2009 8:12 pm

That was fast!
But how long until 5.0.17? And until then, can we identify the exact combinations of ZCS/ZCO/Outlook patch under which the bug manifests itself? For example I don't think I was seeing it with the ZCO included in 5.0.12, even after applying hotfix kb961752. (The grace period on my Zimbra NE demo install just expired so I can't go back and check.)
fsiegel
Zimbra Alumni
Zimbra Alumni
Posts: 1334
Joined: Fri Sep 12, 2014 10:16 pm

Outlook 2007 Service Pack 2

Postby fsiegel » Thu Apr 30, 2009 11:54 am

Well -- 5.0.16 just came out, so I imagine 5.0.17 would be a couple of months away. I'm not sure what combinations work -- I can go back and check various versions and let you know.
Rich Graves
Outstanding Member
Outstanding Member
Posts: 687
Joined: Fri Sep 12, 2014 10:24 pm

Outlook 2007 Service Pack 2

Postby Rich Graves » Thu Apr 30, 2009 12:19 pm

The other forum thread says the problem goes back to at least 5.0.10. If this is a Microsoft change, then I don't know why it wouldn't go all the way back to 5.0.0.
It is not unprecedented for an out-of-cycle ZCO update to show up on support.zimbra.com, without a corresponding full ZCS release. I'd love to see that happen for 37146, which looks much more urgent (to me) than the other things slated for 5.0.17.
Here's our short-term pickle: There are several things in the 5.0.16 server and webmail that we like, notably Bug 32536 – Zimbra too trusting of MIME-type sent by client. But the 5.0.16 server's implementation of Bug 23215 – Eliminate blobs for appointments where possible causes collateral damage on Outlook Connector installs (36534, 35600), essentially requiring us to upgrade all ZCO clients to at least 5.0.16 before upgrading the server.
I don't want to be forced to upgrade everyone's ZCO twice within a couple months. I don't want to wait for 5.0.17 to get all the other goodies in 5.0.16.
I just want to whine, basically.

Return to “Zimbra Connector for Outlook”

Who is online

Users browsing this forum: No registered users and 5 guests