[SOLVED] ZCO 5.0.18 Category icon disappears when Send/Receive

Ask your questions and get help with Zimbra's Outlook Connector.
ja98
Posts: 18
Joined: Fri Sep 12, 2014 11:31 pm

[SOLVED] ZCO 5.0.18 Category icon disappears when Send/Receive

Postby ja98 » Mon Jul 20, 2009 11:04 am

Hi,
After upgrading to ZCS 5.0.18 and installing ZCO 5.0.18...
In Outlook a category can be selected for a mail message, but the category's icon disappears after Send/Receive.
To demonstrate:
- In Outlook mail view, right-click Categories column for a mail message and select a category.

- The selected category's icon appears in the Categories column.

- Press Send/receive (or wait for automatic Send/Receive) and the icon disappears.
I have confirmed this behavior occurs with ZCO 5.0.18. It does not occur with ZCO 5.0.16.
I have attached ZCO logs.
Thanks for any help.

zco-20090719T165016.804-OUTLOOK.EXE-2992.zip



fsiegel
Zimbra Alumni
Zimbra Alumni
Posts: 1334
Joined: Fri Sep 12, 2014 10:16 pm

[SOLVED] ZCO 5.0.18 Category icon disappears when Send/Receive

Postby fsiegel » Mon Jul 20, 2009 11:17 am

See:

Enhancements for 5.0.X

New Features for 5.0.18
In the 5.0.18 release notes
The reason is that local Outlook rules now run automatically. Outlook 2007 has a default rule called Clear categories on Email. Disable that rule (or if possible, delete it entirely).
Unfortunately, it probably synced to the server, and your categories may be gone -- you may have to re-categorize.
So far there is no good way to disable this rule programmatically, although I may have to look into this more.
That's why we put it in the release notes.
ja98
Posts: 18
Joined: Fri Sep 12, 2014 11:31 pm

[SOLVED] ZCO 5.0.18 Category icon disappears when Send/Receive

Postby ja98 » Mon Jul 20, 2009 1:28 pm

Ah, so sorry. I missed that. My fault.
fsiegel
Zimbra Alumni
Zimbra Alumni
Posts: 1334
Joined: Fri Sep 12, 2014 10:16 pm

[SOLVED] ZCO 5.0.18 Category icon disappears when Send/Receive

Postby fsiegel » Mon Jul 20, 2009 1:39 pm

I will still try to deal with this and a subsequent release or patch. People shouldn't have to rely on the release notes.
snissen
Posts: 23
Joined: Fri Sep 12, 2014 11:13 pm

[SOLVED] ZCO 5.0.18 Category icon disappears when Send/Receive

Postby snissen » Tue Jul 28, 2009 2:22 pm

Since this is not a simple registry setting, I assume a programmer would have to use the Outlook API to turn this rule off (or delete it). It would be very helpful if a Zimbra developer (like those who work on the ZCS Connector for Outlook) could post a VBscript that disables or deletes this rule. Sande
snissen
Posts: 23
Joined: Fri Sep 12, 2014 11:13 pm

[SOLVED] ZCO 5.0.18 Category icon disappears when Send/Receive

Postby snissen » Tue Jul 28, 2009 2:47 pm

For example, I can't vouch for this code, but I found it at:


Use">http://doodlescripts.com/News/article/sid=9.html
Use
the code below to disable and enable rules. This could be useful during migrations. This should work for Outlook 2003 & Outlook 2007

=====================================================================

'rules.vbsÂ… On Error Resume Next
Set objOutlook = CreateObject("Outlook.Application")

Set colRules = objOutlook.Session.DefaultStore.GetRules
For Each oRule In colRules

oRule.Enabled = False

Next
colRules.Save
For Each oRule In colRules

oRule.Enabled = True

Next
colRules.Save
Rich Graves
Outstanding Member
Outstanding Member
Posts: 687
Joined: Fri Sep 12, 2014 10:24 pm

[SOLVED] ZCO 5.0.18 Category icon disappears when Send/Receive

Postby Rich Graves » Tue Jul 28, 2009 8:36 pm

For new installs, outlook.exe /cleanrules dumps all rules. That's probably safe for old installs, too, because it's unlikely that any rules that people attempted to define pre-5.0.18 ever actually worked.

Return to “Zimbra Connector for Outlook”

Who is online

Users browsing this forum: No registered users and 3 guests