Zco 7.1.4 disables auto archive!

Ask your questions and get help with Zimbra's Outlook Connector.
Arglex1
Posts: 16
Joined: Fri Sep 12, 2014 9:57 pm

Zco 7.1.4 disables auto archive!

Postby Arglex1 » Wed May 09, 2012 11:40 am

I will be filing a bug request on the support portal - I am posting this info because I found no issue like this on the web.
In the past few weeks, users mailboxes have been very frequently filling up. I sent my techs around to check that the users (ones with mailboxes filling up) had auto archive setup. They verified and forced each computer to archive. No change, mailboxes still full. We went and looked at the archive settings on the folder level. When you check the inbox folder, it has been set to "do not archive" we then set it to use the default archive settings (or any other setting). Press apply, go back to the properties and it is set back to "do not archive"!. I have tried everything on the outlook client to make it work -
FIX: Uninstall Zimbra connector for outlook version 7.1.4 and installed Older Zimbra connector. I went to 7.0.1. Now I can archive again.
Outlook 2007 SP 3

Zimbra professional (server) 7.1.4
Major bug will be filed. We have 325 users on our system and it will fill up all of their quotas fast.


phoenix
Ambassador
Ambassador
Posts: 26414
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Zco 7.1.4 disables auto archive!

Postby phoenix » Wed May 09, 2012 11:57 am

This feature is covered here: Bug 54400 – disable outlook autoarchive by default
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
fang0654
Posts: 16
Joined: Sat Sep 13, 2014 12:26 am

Zco 7.1.4 disables auto archive!

Postby fang0654 » Sat Jun 02, 2012 8:37 am

This 'feature' has been severely hurting our business, since now our clients are filling up their mailboxes, and mail delivery stops for them.
If there is a bug autoarchiving calendar entries, why not just disable it for calendars?
phoenix
Ambassador
Ambassador
Posts: 26414
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Zco 7.1.4 disables auto archive!

Postby phoenix » Sat Jun 02, 2012 9:00 am

[quote user="fang0654"]If there is a bug autoarchiving calendar entries, why not just disable it for calendars?[/QUOTE]Why not read the bug report in detail for changes you can make to this feature?
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
fang0654
Posts: 16
Joined: Sat Sep 13, 2014 12:26 am

Zco 7.1.4 disables auto archive!

Postby fang0654 » Sat Jun 02, 2012 9:28 am

I did. Right now we have a little under 350 users on our system, spread across roughly 70 different clients.
Our choices are to go in for each user and change a registry key, or to build a customized msi, uninstall their current connector, and reinstall the customized one. Additionally, this will need to be done every time we do a mail server upgrade, and a new connector comes out.
If I have my techs do just the registry key, between getting the client on the phone, getting a remote connection established, etc, it'll take on average about 5 minutes to change it. That is 1750 minutes, or about 30 man hours. Using a customized msi, with the uninstall/reinstall will run at least 4x that.
And this is only to restore standard Outlook functionality. Personally, I think AutoArchive is a trainwreck, that with about 5 hours more of programming could have been 10x better. But Zimbra does not provide an alternative to handle the problem of moving the mail off the mail server, but still having it available for reference, without requiring user interaction. And we can't be the only customer getting hit with this.
14643rusty
Advanced member
Advanced member
Posts: 80
Joined: Fri Sep 12, 2014 11:12 pm

Zco 7.1.4 disables auto archive!

Postby 14643rusty » Mon Jun 18, 2012 5:36 pm

So I changed the custom msi script to -daa 0 and after uninstalling and installing with new msi, the DisableAutoArchive registry key is set to 0 as expected.
Now when I go into a folder and change setting to use default archive settings, it stays as set. So far so good.
The problem is, when I run archive, there are no emails which get moved to the archive.pst as they are supposed to. I see something happening for a brief second in the status bar, but it goes away too quick to read. There is so much to archive that it normally would say archiving inbox for a long time.
Is anyone else having the same problem?
Is there a fix?
Thanks.
Edit: forgot to mention ZCS is 7.20 and OutlookConnector is 7.2.1.520_x86
Arglex1
Posts: 16
Joined: Fri Sep 12, 2014 9:57 pm

Zco 7.1.4 disables auto archive!

Postby Arglex1 » Tue Jul 03, 2012 9:34 am

[quote user="10330phoenix"]Why not read the bug report in detail for changes you can make to this feature?[/QUOTE]
Is this what Dev has come to?
We have a small production environment compared to some of the larger deployments out there but having over 100 users (we have over 300) makes it complicated enough. I understand the calendar entries would be lost, but disable that. Now we have all of the users mailboxes hitting max quotas.
Our options are like this:

a: manually change every computer's registry (not an option)

b: roll out a customized installer on every desktop (lots of time)

c: roll back the connector (still lots of time)

d: set everyone's mailbox to only store a certain amount of time of data (does anyone use this?).
Did anyone look at the functional use of completely disabling auto archive? You realize the headache you have now placed on the techs working with this system? Simply disabling calendar archiving would have been enough but the whole thing? What about the amount of storage on the mail system? 15k sas drives are not cheap, that is why people have quotas.
You guys successfully rolled out a "fix" that created a much MUCH larger problem.
Thanks guys.
ewilen
Elite member
Elite member
Posts: 1429
Joined: Fri Sep 12, 2014 11:34 pm

Zco 7.1.4 disables auto archive!

Postby ewilen » Fri Jul 06, 2012 1:38 pm

I can sympathize with the frustration. For my part, even though I was aware of this change when it was incorporated, it's still a hassle during upgrade to have to modify the ZCO installer and then re-install it on the server. (When I do this, I also disable autoupdate, since my users don't have the rights necessary to do the update themselves.)
However, the best place to get the devs attention is via bugzilla. I'd suggest opening an RFE to limit disable auto archive to calendar, and then posting the bug number here. I'll vote for it.

Return to “Zimbra Connector for Outlook”

Who is online

Users browsing this forum: No registered users and 4 guests