Page 1 of 1

Zimbra 7.1.1. and BESX 5.0.3 Issues

Posted: Wed Dec 14, 2011 7:35 am
by glaucom
I have installed BESX 5.0.3 and ZCB
I can't activate any device.

Gal sync is ok and I can create users but when I try the enterprise activation the mail with the dat file remain in the user account.

In the magt log file I find the following errors
0x17CC} Retry start for user:

{0x17CC} Starting handheld for xxxxxx
{0x17CC} MAPIMailbox::MAPIMailbox ServerDN=/ Administrative Group/cn=Configuration/cn=Servers/ Private MDB,

{0x17CC} MailboxManager::GetMailboxSession - Using MAPI profile 'BlackBerryServer'

{0x17CC} {} MAPIMailbox::MAPIMailbox - OpenMsgStore (0x80040107) failed,, ServerDN=/ Administrative Group/cn=Configuration/cn=Servers/ Private MDB

{0x17CC} {} MAPIMailbox::~MAPIMailbox - Exception handled

{0x17CC} MailboxManager::CloseMailboxSession - closing session

User xxxxx not started

{0x17CC} 1 user(s) failed to initialize
If I stop the controller service and connect with outlook I can see the mails.
If I erase the data file of the user involved and restart BES services at first I find in the MAGT log:
{0x17D4} Starting handheld for xxxxxxx

{0x17D4} MAPIMailbox::MAPIMailbox ServerDN=/ Administrative Group/cn=Configuration/cn=Servers/ Private MDB,

{0x17D4} MailboxManager::GetMailboxSession - Using MAPI profile 'BlackBerryServer'

{0x17CC} Sending REPORT_HEALTH_SCORE command to Dispatcher, Health=0x000000000000150F, Mask=0x000000000200150F, Users=0, Servers=0

{0x17D4} {} MAPIMailbox::MAPIMailbox - Mailbox opened on session 0x03F322E8 (MAIL.TEATROREGIO.TORINO.IT)

{0x17D4} {} MAPIMailbox::SetRefIdSearchCriteria - creating search folder

{0x17D4} {} MAPIMailbox::SetMsgOnDeviceSearchCriteria - creating search folder

{0x17D4} PMDatabase::OpenNamedFolder: opening existing folder 'BlackBerryHandheldInfo'

{0x17D4} PMDatabase::OpenNamedFolder: opened an existing folder 'BlackBerryHandheldInfo'

{0x17D4} Pager::OpenClientDatabase: invalid number of messages in client folder , num msg = 0

{0x17D4} OpenDatabase() failed for xxxxxxx

{0x17D4} User xxxxxx not started
and then next tries I can find the same error reported above (OpenMsgStore (0x80040107) failed).
Glauco Marini

Zimbra 7.1.1. and BESX 5.0.3 Issues

Posted: Thu Dec 29, 2011 9:45 pm
by bthom73
Hi Glauco,
Were you able to find any solution to this issue?
We're experiencing the same "MAPIMailbox::MAPIMailbox - OpenMsgStore (0x80040107) failed" problem, also with BES 5.0.3
We're attempting to run Zimbra server 6.0.8 with ZCB 6.5.6 and BES 5.0.3 which from the documentation appears to be a match version wise.
Also, just in case it helps, I'm able to make the devices communicate for a short period of time by stopping the Blackberry Controller service, doing a repair on the ZCB 6.5.6 connector by running the installer again and choosing "repair", and then restarting the Blackberry Controller service. It only stays working for a few minutes though, so it seems that something is automatically breaking whatever it is that the ZCB repair is fixing.


Zimbra 7.1.1. and BESX 5.0.3 Issues

Posted: Fri Dec 30, 2011 1:28 am
by glaucom
Hi Brian,

first of all we disinstalled all the security upgrades related to Microsoft Office installed by windows update with the exception of service pack 2, stopped automatic updates, then disinstalled and reinstalled BESX and we had the same problem. Then we disinstalled the connector and erased the profiles. After recreating the profiles and reinstalling the connector it begun to work.

Now everything is working.
Hope it helps.
Glauco Marini


Zimbra 7.1.1. and BESX 5.0.3 Issues

Posted: Sat Dec 31, 2011 3:01 pm
by bthom73
Hi Glauco,
I followed your lead and reverted back to an old backup (BES 4.1.6), turned off automatic updates completely, installed SP2 for Office 2007 using the manual file, then upgraded to BES 4.1.7 (a prereq for 5.x), and then finally installed ZCB 6.5.7 and upgraded to BES 5.0.2 (thinking that there may be best to go with a version that has more testing than the absolute latest version).
After all that I still ran into the same issue of it working for a few minutes and then failing.
Finally, after opening a support ticket they suggested basically the same thing you mentioned regarding recreating the profiles except they said to only delete/recreate the BlackBerryServer_MailStoreProfile profile and leave the BlackBerryServer profile untouched. That seems to have worked and the server has now been up and running for the past 24hrs without issues.
I don't have a good feeling about it though, not understanding how/why just deleting that one profile made the difference between an unstable and stable installation. Especially since the BlackBerryServer_MailStoreProfile was already a new profile just previously created as part of the ZCB 6.5.7 installation (not needed for the previous BES 4.1.x configuration).
Long story short, although it's working I'm afraid to even touch it/reboot it. I'll ask the support tech to follow up this thread with the logic as to why deleting/recreating that (new) BlackBerryServer_MailStoreProfile stabilized the installation.


Zimbra 7.1.1. and BESX 5.0.3 Issues

Posted: Mon Jan 02, 2012 1:56 am
by glaucom
Hi Brian,

I'm glad that your installation is up and running, I have the same feeling as you about the stability of the system. Let me know if you have any news about this subject.
Happy new year

Zimbra 7.1.1. and BESX 5.0.3 Issues

Posted: Sat Jan 07, 2012 7:53 pm
by bthom73
Hi Glauco,
I communicated with the support tech again and they gave me some additional background info.
If I'm following correctly, the issue is related to OLMAPI32.DLL and EMSMDB32.DLL in conjunction with the BlackBerryServer and BlackBerryServer_MailStoreProfile profiles.
During the upgrade process from BES 4.1.6 to BES 5.0.2 I was dealing with three different versions of each of those two DLLs - the Microsoft version included with MS Office 2007, the Zimbra version included with ZCB 6.0.8, and the Zimbra version included with ZCB 6.5.7.
Long story short, I may have created the BlackBerryServer_MailStoreProfile too early in upgrade process prior to ZCB 6.5.7 version of those two DLLs being in place. Still not sure if it was the ZCB 6.0.8 version (pre-existing from the BES 4.1.6 setup) or the Microsoft version (possibly installed during the SP2 upgrade for Office 2007) that caused the issue, but in any case it appears that creating BlackBerryServer_MailStoreProfile prior to the newer ZCB (6.5.7) version of those DLLs being in place is what caused the problem.
If I understand correctly, the underlying issue is that when the wrong version of the DLLs are installed (either the Microsoft version or the older ZCB 6.0.8 version), the BlackBerryServer_MailStoreProfile ends up pointing to the same ZDB database files as the BlackBerryServer profile, which causes possible corruption and doesn't function correctly. In a functional BES 5.0.2/ZCB 6.5.7 installation the BlackBerryServer_MailStoreProfile should point at its own separate ZDB file, not the ZDB file associated with the BlackBerryServer profile. The newer ZCB version of the DLLs is required in order to keep those ZDB database files separated into two separate files. Deleting and recreating the BlackBerryServer_MailStoreProfile after the correct version of the DLLs are installed creates the second ZDB database file and from that point forward everything should stay working correctly unless the installation of Automatic Updates or manually installing a MS service pack that contains either of those two DLLs puts the Microsoft version back in place of the newer ZCB version.
Hope that makes sense, and if my understanding of any of the above is incorrect I'm hoping that someone here in the forums will follow up with a correction.


Zimbra 7.1.1. and BESX 5.0.3 Issues

Posted: Fri Nov 30, 2012 4:41 am
by aiko
Thank you!
I had some tough days after doing the usual security updates...

The Blackberry sync stopped after several hours. So I restarted the blackberry services from time to time and did a full ZDB Scanpst for each mailbox each time...
Also seen in the logs before stopping syncing:

Testing SERVERNAME health, returned 0x80040119
Recreating the BlackBerryServer_MailStoreProfile helped.
Thanks again,


Re: Zimbra 7.1.1. and BESX 5.0.3 Issues

Posted: Sat Jan 07, 2017 7:23 pm
by bthom73
I just ran into exactly the same issue two weeks ago. The issue started with the SSL certificate expiring on the Zimbra server and the new certificate being SHA2 instead of SHA1. That broke the entire Zimbra/BES setup and turned into a two week nightmare of trial&error and upgrades.

Oddly enough in google searching trying to find a solution to the errors in the BES MAGT logs I ran across this forum thread and it happened to be myself from five years ago. The issue was simply a new flavor of the same above and is now resolved although Zimbra wasn't willing to provide support despite having a support contract due to the age of the config.

In any case, the current config is now Windows Server 2008 SP2 on the BES (previously 2003R2). The BES is 5.0.3mr8 (previously 5.0.1). The Zimbra server is 7.2.1 32bit (unchanged). The ZCB version is 7.2.3 (previously 7.2.1). And now the cert between the BES and the Zimbra server is SHA2 encrypted.

After two weeks of trial&error it would be difficult for me to say exactly which DLL versions resolved the issue but if anyone runs into the same issue please feel free to post and I'll check to see which version of any specific DLL(s) are installed. I'm just glad everything is working again...