Stuck on installation of ZCB Beta3

Are you using the Zimbra Connector for BlackBerry? Post your comments and questions here.
stich86
Advanced member
Advanced member
Posts: 123
Joined: Fri Sep 12, 2014 11:10 pm

Stuck on installation of ZCB Beta3

Postby stich86 » Mon Aug 18, 2008 7:35 am

sorry if i never reply before, but i was on holiday..
i just checked today via RDP that the mapi32.dll is the wrong file (622kb..), i've done the same workaround of rduric, putting the old dll of Beta 2, and Mail apps doesn't hangs..
but if it's possibile, anyone can send us the mapi32.dll of Outlook 2007?
thanks :)
EDIT: the file is about 113kb of size and the version is: 1.0.2536.0? i've restore mapi32.dll with fixmapi.exe on system32 directory..


10339alee
Zimbra Alumni
Zimbra Alumni
Posts: 406
Joined: Fri Sep 12, 2014 10:31 pm

Stuck on installation of ZCB Beta3

Postby 10339alee » Mon Aug 18, 2008 12:52 pm

[quote user="stich86"]sorry if i never reply before, but i was on holiday..
i just checked today via RDP that the mapi32.dll is the wrong file (622kb..), i've done the same workaround of rduric, putting the old dll of Beta 2, and Mail apps doesn't hangs..
but if it's possibile, anyone can send us the mapi32.dll of Outlook 2007?
thanks :)
EDIT: the file is about 113kb of size and the version is: 1.0.2536.0? i've restore mapi32.dll with fixmapi.exe on system32 directory..[/QUOTE]
i just filed a bug on this issue:
Bug 30890 – BB: ZCB picks up wrong version of mapi32.dll
i'm going to investigate to see why we get in this state at times.
regarding map32.dll, the one that you are using is fine if it is working. that dll should only be routing calls to another DLL and that looks like it is working.
10339alee
Zimbra Alumni
Zimbra Alumni
Posts: 406
Joined: Fri Sep 12, 2014 10:31 pm

Stuck on installation of ZCB Beta3

Postby 10339alee » Mon Aug 18, 2008 7:58 pm

[quote user="10339alee"]i just filed a bug on this issue:
Bug 30890 – BB: ZCB picks up wrong version of mapi32.dll
i'm going to investigate to see why we get in this state at times.
regarding map32.dll, the one that you are using is fine if it is working. that dll should only be routing calls to another DLL and that looks like it is working.[/QUOTE]
for everyone that is having this problem...can you post the location, version and size of mapi32.dll along with mapistub.dll?
i just built a clean windows 2003 enterprise edition with ZCB and this dll seems ok and everything works fine.
rduric
Posts: 25
Joined: Fri Sep 12, 2014 11:43 pm

Stuck on installation of ZCB Beta3

Postby rduric » Mon Aug 18, 2008 8:49 pm

mapi32.dll is in c:windowssystem32 135 KB, a copy from ZCO Beta 2;

mapistub.dll in c:windowssystem32, 113 KB
I also installed W2K3 Enterprise from the scratch and W2K3 SP2; ExchangeMapiCdo.EXE (MAPI/CDO 1.2.1); Outlook 2007 and SP1; BES 4.1.6 and ZimbraBESConnector-5.0.9_GA_2469_5.0.2672.9.msi.
My ZCB appears to be working once I copied the mapi32.dll from my Beta 2 server (outlook 2003). Should I get the mapi32.dll, size 113 KB (Outlook 2007)? Thanks.
10339alee
Zimbra Alumni
Zimbra Alumni
Posts: 406
Joined: Fri Sep 12, 2014 10:31 pm

Stuck on installation of ZCB Beta3

Postby 10339alee » Mon Aug 18, 2008 8:54 pm

[quote user="rduric"]mapi32.dll is in c:windowssystem32 135 KB, a copy from ZCO Beta 2;

mapistub.dll in c:windowssystem32, 113 KB
I also installed W2K3 Enterprise from the scratch and W2K3 SP2; ExchangeMapiCdo.EXE (MAPI/CDO 1.2.1); Outlook 2007 and SP1; BES 4.1.6 and ZimbraBESConnector-5.0.9_GA_2469_5.0.2672.9.msi.
My ZCB appears to be working once I copied the mapi32.dll from my Beta 2 server (outlook 2003). Should I get the mapi32.dll, size 113 KB (Outlook 2007)? Thanks.[/QUOTE]
when you installed the mapi/cdo 1.2.1 package..did it create a folder in

program files called exchangemapi?

or is there no folder that looks like that? i'm trying to track down if it is a potential problem with the older cdo/mapi download that installed everything into system32 instead of into its own folder.
thanks

--Tony
10339alee
Zimbra Alumni
Zimbra Alumni
Posts: 406
Joined: Fri Sep 12, 2014 10:31 pm

Stuck on installation of ZCB Beta3

Postby 10339alee » Tue Aug 19, 2008 12:05 am

[quote user="10339alee"]when you installed the mapi/cdo 1.2.1 package..did it create a folder in

program files called exchangemapi?

or is there no folder that looks like that? i'm trying to track down if it is a potential problem with the older cdo/mapi download that installed everything into system32 instead of into its own folder.
thanks

--Tony[/QUOTE]
verified that the old versions of the mapi/cdo download (the one that doesn't create the program filesexchangemapi folder) updates mapi32.dll to the version that will not work with ZCB. the fix for this is to backup mapi32.dll to something like mapi32.dll.zco and then run an app called fixmapi.exe that is located in windowssystem32

other solutions like copying mapi32.dll from an older, working version of ZCB will do the trick too since it is getting a version of mapi32.dll that works.
we will do something in the installer to make this work around not required but for now, if you are seeing this problem, run fixmapi.exe
rduric
Posts: 25
Joined: Fri Sep 12, 2014 11:43 pm

Stuck on installation of ZCB Beta3

Postby rduric » Tue Aug 19, 2008 8:03 am

the mapi/cdo 1.2.1 package did NOT create the c:program filesexchangemapi folder. This morning I ran the fixmapi.exe, restarted the server, the mapi32.dll is 113 KB and ZCB is working. Thanks Tony.
SSM
Posts: 4
Joined: Fri Sep 12, 2014 11:47 pm

Stuck on installation of ZCB Beta3

Postby SSM » Sun Sep 21, 2008 5:58 am

Hi

I am using Zimbra Network Edition 5.0.9 and BES 4.1.3 and installed all these as per the ZCB docs. But still unable create BlackBerryManager / Server Profiles.

OS- MAC os 10.5.4

Zimbra - NE 5.0.9
Windwos 2003 sp2

Exchange MAPI /CDO 1.2.1

BES 4.1.3

OUTLOOK 2007 + sp1

stopped Blackberry Controller

Installed ZCB 5.0.10 GA

Unable to create BlackberryManager / Server
Nslookup

Telnet to 7071 and 443 all are ok
Pls help me on this.
10339alee
Zimbra Alumni
Zimbra Alumni
Posts: 406
Joined: Fri Sep 12, 2014 10:31 pm

Stuck on installation of ZCB Beta3

Postby 10339alee » Tue Sep 23, 2008 6:59 pm

[quote user="SSM"]Hi

I am using Zimbra Network Edition 5.0.9 and BES 4.1.3 and installed all these as per the ZCB docs. But still unable create BlackBerryManager / Server Profiles.

OS- MAC os 10.5.4

Zimbra - NE 5.0.9
Windwos 2003 sp2

Exchange MAPI /CDO 1.2.1

BES 4.1.3

OUTLOOK 2007 + sp1

stopped Blackberry Controller

Installed ZCB 5.0.10 GA

Unable to create BlackberryManager / Server
Nslookup

Telnet to 7071 and 443 all are ok
Pls help me on this.[/QUOTE]
did you get any errors installing ZCB? might want to run the installer again to make sure that there are no DLL conflicts. if you still can't create the profile, you should enable ZCB logging before trying to create the profiles and then send the logs to support.
in terms of the DLL conflict issue...check for mspst32.dll in windowssystem32 and mapi32.dll in windowssystem32. mapi32.dll should be the same size as mapistub.dll and mspst32.dll should either not be there (but it is ok if mspst32.dll.zco is there) or it should be the same file as the one that gets installed with Outlook 2007.
support can help you more.
--Tony
SSM
Posts: 4
Joined: Fri Sep 12, 2014 11:47 pm

Stuck on installation of ZCB Beta3

Postby SSM » Wed Sep 24, 2008 12:55 am

Thanks Tony ,
Ys there was a issue with DLL , i did the same what you mentioned now i could able to create profiles.
thanks for your prompt reply.

Return to “Zimbra Connector for Blackberry”

Who is online

Users browsing this forum: No registered users and 4 guests