Zimbra Desktop doesn't run on 64 bit Ubuntu 14.04 (XPCOM issue)

Need some help getting Zimbra Desktop set up and working?
mariner92
Posts: 1
Joined: Fri Sep 12, 2014 4:04 pm

Zimbra Desktop doesn't run on 64 bit Ubuntu 14.04 (XPCOM issue)

Postby mariner92 » Fri Sep 12, 2014 4:21 pm

During installation, installer complained of no ia32-libs (which I don't believe is maintained for 14.04).  Any suggestions are greatly appreciated.



User avatar
tonster
Zimbra Employee
Zimbra Employee
Posts: 312
Joined: Fri Feb 21, 2014 10:14 am
Location: Ypsilanti, MI
ZCS/ZD Version: Release 8.7.0_GA_1659.RHEL6_64_2016

Zimbra Desktop doesn't run on 64 bit Ubuntu 14.04 (XPCOM issue)

Postby tonster » Sun Sep 14, 2014 9:13 am

At this time ZD isn't supported on Ubuntu 14.04. There was some discussion on the previous boards about some people getting it to work, but I have no easy way to get to that now.
dirkjanvanderwal
Posts: 8
Joined: Tue Sep 16, 2014 2:49 am

Zimbra Desktop doesn't run on 64 bit Ubuntu 14.04 (XPCOM issue)

Postby dirkjanvanderwal » Tue Sep 16, 2014 3:11 am

Hello mariner92

I am using Zimbra Desktop on Ubuntu 14.04 64 bit (Unity) on a daily basis. You'll have to do some extra work prior to installation.

To install the 32bit dependecies you'll have to execute the following command in a terminal:

sudo apt-get install libgtk2.0-0:i386 libnss3-1d:i386 libnspr4-0d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386

After that just follow the instructions in the Zimbra installation manual. However do not install a root user but carefully follow the steps to install an standard user. Otherwise you will not be prompted to start Zimbra Desktop after the installation finishes and finding the right way to start Zimbra via Unity is annoying.

As soon as you have Zimbra running remember to pin it to the launcher for future use.

judav
Posts: 1
Joined: Fri Sep 26, 2014 10:14 am

Zimbra Desktop doesn't run on 64 bit Ubuntu 14.04 (XPCOM issue)

Postby judav » Fri Sep 26, 2014 10:31 am

Hello


I'm trying to use Zimbra Desktop 7.2.5 with Ubuntu 14.04.1 LTS.


I've followed your instructions and everything is fine during the installation.


but, whene i tryed to start Zimbra Desktop i'v got this error :


/usr/local/src$ /opt/zimbra/zdesktop/linux/prism/zdclient: error while loading shared libraries: libasound.so.2: cannot open shared object file: No such file or directory


So I have tried the following :


sudo apt-get install ia32-libs


And I get the following message :


Package ia32-libs is not available, but is referred to by another package.


This may mean that the package is missing, has been obsoleted, or


is only available from another source


However the following packages replace it:


 lib32z1 lib32ncurses5 lib32bz2-1.0


E: Package 'ia32-libs' has no installation candidate


 


So ... I don't know what to do :(


 


thanks for your help

metux
Advanced member
Advanced member
Posts: 146
Joined: Mon Jul 28, 2014 6:21 pm

Zimbra Desktop doesn't run on 64 bit Ubuntu 14.04 (XPCOM issue)

Postby metux » Mon Sep 29, 2014 4:26 am

Why not just recompiling it for 64bit ? Is it really so hard ?
dirkjanvanderwal
Posts: 8
Joined: Tue Sep 16, 2014 2:49 am

Zimbra Desktop doesn't run on 64 bit Ubuntu 14.04 (XPCOM issue)

Postby dirkjanvanderwal » Wed Oct 01, 2014 2:33 am

Strange, it works over here. Might have soemthing to do that I am on a Developer Edition XPS13 wich also uses Dell repositories.



Since there are replacements indicated, did you try after installing them?
User avatar
ppearl
Zimbra Employee
Zimbra Employee
Posts: 114
Joined: Thu May 15, 2014 7:36 am

Zimbra Desktop doesn't run on 64 bit Ubuntu 14.04 (XPCOM issue)

Postby ppearl » Wed Oct 01, 2014 10:03 am

> ... libasound.so.2: cannot open shared object file: No such file or directory


Based on the error you have shown, it looks like you're missing libasound.   I've not tried it myself, but my expectation is that you'll need to install libasound2 to address this:


http://packages.ubuntu.com/search?suite=trusty§ion=all&arch=any&keywords=libasound&searchon=names

metux
Advanced member
Advanced member
Posts: 146
Joined: Mon Jul 28, 2014 6:21 pm

Zimbra Desktop doesn't run on 64 bit Ubuntu 14.04 (XPCOM issue)

Postby metux » Thu Oct 02, 2014 12:31 am

You'll need the 32bit version of libalsa ... not sure whether it's still shipped in Ubuntu.
esigande
Posts: 3
Joined: Wed Jun 10, 2015 3:01 am

Zimbra Desktop doesn't run on 64 bit Ubuntu 14.04 (XPCOM issue)

Postby esigande » Wed Jun 10, 2015 3:49 am

Hi Judav,

I have found myself with this exact problem and i have searched around for a fix..the various suggestions still fail for me.

Have you resolved this problem?if so please share so i can also install Zimbra Desktop 7.2.5 on Ubuntu Desktop 14.04 LTS

Thank you.

Edwin.
User avatar
ppearl
Zimbra Employee
Zimbra Employee
Posts: 114
Joined: Thu May 15, 2014 7:36 am

Zimbra Desktop doesn't run on 64 bit Ubuntu 14.04 (XPCOM issue)

Postby ppearl » Wed Jun 10, 2015 8:15 pm

Have you considered trying the new Zimbra Desktop 7.2.7 Beta? https://community.zimbra.com/desktop/f/1899/t/1139348

Return to “Installation Help”

Who is online

Users browsing this forum: No registered users and 2 guests