Missing Library libXss.so1 [SOLVED]

Need some help getting Zimbra Desktop set up and working?
User avatar
Posts: 14
Joined: Tue Sep 30, 2014 12:37 pm
ZCS/ZD Version: ZDesktop 7.3.1 ZCS 8.8.10

Missing Library libXss.so1 [SOLVED]

Postby themetman » Thu May 18, 2017 7:39 am

I am delighted to have a 64bit version of Zimbra Desktop AT LAST!!!
I am using the new 7.3.0 with CentOS 7.3 running kernel 3.10
Imagine my disappointment having installed it on my CentOS 7 Box only to get this error:

Code: Select all

/opt/zimbra/zdesktop/linux/node-webkit/zdesktop: error while loading shared libraries: libXss.so.1: cannot open shared object file: No such file or directory

Surely the Install Script should check for missing dependencies?
Well. I had a big problem with the 7.2.8-Beta not finding java, but got round that one by editing the Zimbra Desktop code..
The libXss library is not found when I look for it using:

Code: Select all

yum whatprovides libXss

Anyway a quick search on DuckDuckGo revealed that the library is part of the libXScrnSaver package
However for anyone out there having the same problem, I thought I would post the solution.

Code: Select all

yum install libXScrnSaver

and Bingo!!!
Hope this helps someone.

Return to “Installation Help”

Who is online

Users browsing this forum: No registered users and 3 guests