Zimbra rechaza correos en local pero no en desarrollo

biooib
Posts: 1
Joined: Tue Sep 14, 2021 12:53 pm

Zimbra rechaza correos en local pero no en desarrollo

Postby biooib » Tue Sep 14, 2021 1:01 pm

Hola,

tengo una aplicación java (JAVA MAIL API)con la que envío correos smtp a través de Zimbra.

Si envío un correo desde mi máquina local (Tomcat + aplicacionjava.war) a una cuenta que no existe en mi propia estafeta, Zimbra devuelve un error:

EBUG SMTP: use8bit false
MAIL FROM:<admin@domainxxxxxx.es>
250 2.1.0 Ok
RCPT TO:<user1@domainxxxxxx.es>
550 5.1.1 user1@domainxxxxxx.es>: Recipient address rejected: domainxxxxxx.es>
DEBUG SMTP: Invalid Addresses
DEBUG SMTP: user1@domainxxxxxx.es
DEBUG SMTP: Sending failed because of invalid destination addresses
RSET
250 2.0.0 Ok
javax.mail.SendFailedException: Invalid Addresses; nested exception is:com.sun.mail.smtp.SMTPAddressFailedException: 550


Pero Si envío un correo desde mi máquina de desarrollo a una cuenta que no existe, incluso en mi propia estafeta, Zimbra no devuelve ningún error y
es como si enviara el correo correctamente,pero en realidad no es así. Pero tampoco produce ningún error.

Es posible que haya una ACL o algo similar en la configuración para mi IP local y rebote los correos.

Ya se que no es posible saber si al enviar un correo a un dominio que no es el mío, mi estafeta sepa
si existe o no. Pero una cuenta de mi propia estafeta que no existe, ¿no debería saberlo al menos?.

Lo que no entiendo es porque detecta en local que la cuenta no existe al enviarla,
sin embargo en el servidor de desarrollo, parece que no hay ningún control a la hora de enviarlo y
detectar el error.




¿Algún consejo?

Saludos


Return to “Spanish”

Who is online

Users browsing this forum: No registered users and 1 guest