Port forwarding SSL and Zimbra Mobile not working

Take your Zimbra with you!
ejittles
Posts: 8
Joined: Sat Sep 13, 2014 1:52 am

Port forwarding SSL and Zimbra Mobile not working

Postby ejittles » Thu Jun 23, 2011 4:23 pm

First and foremost, I apologize if this is a duplicate. I couldn't find anything similar when I searched. Anyway, on with the show:
I only have one public IP address. On the server it is assigned to, I run Zimbra Network Edition. I also have Apache running without SSL. I'd like to enable SSL so that I may run SVN through it. I found a guide on how to reconfigure Zimbra to a different SSL port and then reconfigure Apache to redirect traffic for the mail server to that port.
When that was all said and done, Zimbra worked perfectly through a web browser. It would not work via an Exhange setup on an iPhone or an Android device. It indicated that it could not connect to the server.
Looking at my zimbra logs, the connect never seems to actually make it to the Zimbra server. Nothing in the Apache logs indicate an error. The phone does not provide any valuable logging information.
Here is my Apache config:


ServerName svn.myserver.com

DocumentRoot /var/www/test





ServerName svn.myserver.com

DocumentRoot /var/www/ssl

SSLEngine on

SSLOptions +StrictRequire

SSLCertificateFile /etc/apache2/ssl/apache.pem





ServerName mail.myserver.com

SSLEngine on

SSLProtocol all -SSLv2

SSLCipherSuite ALL:!ADH:!EXPORT:!SSLv2:RC4+RSA:+HIGH:+MEDIUM:+LOW

SSLCertificateFile /opt/zimbra/ssl/zimbra/server/server.crt

SSLCertificateKeyFile /opt/zimbra/ssl/zimbra/server/server.key

Redirect / https://mail.myserver.com:60443/[/url]




I'm completely stumped by this. Does anyone have any ideas? Thank you for taking the time to help me out.


ejittles
Posts: 8
Joined: Sat Sep 13, 2014 1:52 am

Port forwarding SSL and Zimbra Mobile not working

Postby ejittles » Tue Jul 26, 2011 2:04 pm

Sorry to bump this, I am trying to be patient for the right person to come across this. Any ideas?
9540Oxygen
Posts: 2
Joined: Sat Sep 13, 2014 1:44 am

Port forwarding SSL and Zimbra Mobile not working

Postby 9540Oxygen » Fri Dec 30, 2011 9:39 am

Did you set the server address as 'mail.myserver.com:60443' on your Android device? It works on my HTC Wildfire S.
ejittles
Posts: 8
Joined: Sat Sep 13, 2014 1:52 am

Port forwarding SSL and Zimbra Mobile not working

Postby ejittles » Fri Dec 30, 2011 12:53 pm

I did not. I was hoping that the android device would be able to just follow the port forward, just as the web browser does. I didn't want to force everyone to change the settings on their mobile device, so I just run HTTPS on a different IP address now.
9540Oxygen
Posts: 2
Joined: Sat Sep 13, 2014 1:44 am

Port forwarding SSL and Zimbra Mobile not working

Postby 9540Oxygen » Fri Dec 30, 2011 9:26 pm

Yep, it's easier to run Zimbra on a separate IP.
In fact, I tried both Redirect and Proxy from Apache to 60443 port, no success. At present we have to specify the port number on Android devices.

Return to “Mobility”

Who is online

Users browsing this forum: No registered users and 2 guests