Page 1 of 1

Recover a deleted account

Posted: Thu Nov 21, 2019 1:32 pm
by mmantelclst
Hello,
I want to try the network edition of zimbra, for the backup-ng module.
I have one account, I send emails to this account, after that I delete the account and I try to recover it with :

Code: Select all

zxsuite backup doRestoreOnNewAccount test2@domain.tld test2@domain.tld last


The account is recreated but with nothing inside the inbox. I just have my sendbox correct. I don't understand why. There is something I miss there ?
Thank you a lot.

Re: Recover a deleted account

Posted: Thu Nov 21, 2019 10:49 pm
by axslingr
I guess the obvious question is...did you do a backup after you sent the email before you deleted the account?

Lance

Re: Recover a deleted account

Posted: Fri Nov 22, 2019 8:38 am
by mmantelclst
It's not a RealTimeBackup ?
What I understand is when a item is created, is created also in the backup folder ( and compress etc...)
I try to execute the smartscan before delete my account, but that's not changing something.

I have success to restore my account with the last received mail only when i wait a long time before execute the deletion of the account.
Why i have to wait for the last emails to be in the backup ?

Thank you !

Re: Recover a deleted account

Posted: Fri Nov 22, 2019 3:53 pm
by axslingr
You're correct, it is realtime. I just tested on my server and it works as expected. I created a test account, sent an email to it, deleted it immediately, restored and can see the test email I sent in the test account inbox.

Lance

Re: Recover a deleted account

Posted: Mon Nov 25, 2019 8:35 am
by mmantelclst
Very strange, I tried again like you ( create account -> send a email to it -> Delete it right after -> Restore the account with the GUI ) and i don't have the email sent.

Maybe it's just our test machine ...