Page 1 of 1

[Nextcloud 12] New app

Posted: Thu Oct 05, 2017 10:36 pm
by jorgedlcruz
Hi, guys,
Zextras have updated the Nextcloud repository, and now includes an app for Nextcloud 12, you can download it from here on your Nextcloud server:

As you remember, Zimbra Drive remains as beta, so any feedback you might have, please let us know here to improve the product in future updates.

Thank you

Re: [Nextcloud 12] New app

Posted: Fri Oct 06, 2017 11:02 am
by scantec
It now connect ok with Nexcloud 12,

But I can't upload files to the cloud, getting an "Unknown status code" - seems on zimbra side

from mailbox.log
SoapEngine - Only BatchRequest does not have a handler mapped to it. Request: /service/soap/BatchRequest, does not have a handler, log for future handling.

Re: [Nextcloud 12] New app

Posted: Fri Oct 06, 2017 4:25 pm
by BurntTech
Updating Nextcloud 11 to 12 worked. I can see files in the drive app in zimbra. The login in nextcloud with zimbra creds feature isn't working. If you delete the user and click the drive tab it does indeed create the user again and default documents. The login still fails after having drive app create the account again. Tried entering the options into the drive options in nextcloud again and the test still passes but no logins. It was going to update 0.8.14 but ended up on 0.8.15 for nextcloud app. Zimbra is 8.7.11. Logs in nextcloud don't show anything but failed login, ill look to see if there is a verbose option. Any ideas or more information needed?

Small Edit, I tried uploading too and get the unknown status during uploads. Not sure if that error is related to the login feature too?

Re: [Nextcloud 12] New app

Posted: Fri Oct 06, 2017 5:02 pm
by BurntTech
Verbose Logs in nextcloud don't show any extra help. Going through the mailbox log I found a failed lookup for user and invalid authtoken which would seem related

2017-10-06 11:53:19,005 INFO [qtp1068934215-37440:https:https://REPLACEDIP/service/extension/nginx-lookup] [] nginxlookup - user not found:REPLACEDUSERHASH
2017-10-06 11:53:19,045 INFO [qtp1068934215-37445:https:https://REPLACEDDOMAIN/service/soap/NoOpRequest?zauthtoken=REPLACEDAUTHTOKEN] ] [ip=REPLACEDIP;port=54390;] SoapEngine - no valid authtoken present: unable to construct SOAP context

Re: [Nextcloud 12] New app

Posted: Tue Oct 10, 2017 3:22 pm
by L. Mark Stone
Hi Jorge,

I'm running Zimbra 8.8.4 with separate nextcloud 12 server and the latest .15 Zimbra Drive app.

Like the poster here viewtopic.php?f=58&t=62875&p=279229#p279229 I am able to login to Zimbra as a Zimbra user, and nextcloud successfully creates the user's files directory in the nextcloud data directory OK.

But I have a few problems:

1. I can't upload any files (though I can create new folders) to any folders.
2. Double-clicking a file downloads the file, and removes it from the listing in the Zimbra web UI, but the file still exists on the nextcloud server in the user's data directory. Right-clicking on the file and selecting "Download" works properly. The file also still exists in the NextCloud UI if the same user logs in there directly.
3. Right-clicking a folder in Zimbra Drive and selecting "Folder Sync Settings" does nothing.
4. Right-clicking a folder in Zimbra Drive and selecting "Download Folder" works OK, except for the very top "Drive" folder. Perhaps this is intentional?
5. Right-clicking a folder in Zimbra Drive and selecting "Rename Folder" works OK.

Hope that helps,

P.S. There is already a bugzilla for Zimbra Drive Support and Nextcloud 12:

Re: [Nextcloud 12] New app

Posted: Wed Oct 18, 2017 2:38 pm
by BurntTech
I ended up reverting back and all is well again, Is that bug been acknowledged?

Re: [Nextcloud 12] New app

Posted: Thu Oct 19, 2017 4:37 am
by hmobron
Hello BurntTech,

Till wich version you reversed back and how did you download it?

When i go to the download page i always got the latest version.