[SOLVED] Autocomplete keyboard nav broken

Discuss your pilot or production implementation with other Zimbra admins or our engineers.
Rich Graves
Outstanding Member
Outstanding Member
Posts: 687
Joined: Fri Sep 12, 2014 10:24 pm

[SOLVED] Autocomplete keyboard nav broken

Postby Rich Graves » Mon Apr 11, 2011 5:31 pm

We upgraded from 6.0.9 to 6.0.12p1 recently.
A user reports, and I confirm:
When I type a name, the list comes up as expected, and if the first entry is the one you want, it works as expected: return/semicolon/comma/etc cause the selected address to be placed in To/Cc. But if you want one of the other entries, using the keyboard to complete the address is broken (clicking with the mouse always works):
a) arrow down and hit comma or semicolon: "@domain.com" is appended to what you've typed so far. E.g. if I've typed "nancy" and arrow down to her correct entry, what I get is nancy@domain.com.
b) arrow down and hit return: does not autocompletes, and selection is reset to the first entry. At this point you can arrow down to the desired entry and then things work like it should (and like it does for the first entry): semicolon/comma/return/etc cause the selected entry to autocomplete.
I get the same result with IE 8 (Win), Safari (Mac) and FF (both Win and Mac).
The user is sure that everything was fine in 6.0.9. It's possible that it was fine for the brief period we were running 6.0.12, i.e., that it broke with 6.0.12p1.


Rich Graves
Outstanding Member
Outstanding Member
Posts: 687
Joined: Fri Sep 12, 2014 10:24 pm

[SOLVED] Autocomplete keyboard nav broken

Postby Rich Graves » Tue Apr 12, 2011 1:15 pm

Previously reported bug. Fixed for 7.1, but will not be fixed for 6.x. Unclear at what point between 6.0.9 and 6.0.12p1 it broke, but it doesn't really matter.

Workarounds/related">https://bugzilla.zimbra.com/show_bug.cgi?id=58820
Workarounds/related
bugs:
- The "Forget" link is broken for "compose in new window," https://bugzilla.zimbra.com/show_bug.cgi?id=58837 . This made it impossible for the user to remove the errant autocomplete #1. You can (temporarily) change preferences to compose as a tab (which is the default) instead, and then "Forget" properly removes the entry. Or, better, just remove autocomplete #1 from your Address Book(s) entirely.
- Use the mouse instead of the keyboard.

Return to “Administrators”

Who is online

Users browsing this forum: No registered users and 14 guests