Hide from GAL not honored in Desktop?

If Zimbra Desktop had a sync failure, it may have told you to post your error in this section.
kbrokaw
Posts: 5
Joined: Wed Feb 20, 2019 9:18 pm
Location: Maine, USA
ZCS/ZD Version: 8.8.10_GA_3716 CentOS 7

Hide from GAL not honored in Desktop?

Postby kbrokaw » Wed Feb 20, 2019 9:30 pm

I've recently completed a cutover to Zimbra 8.8.10 (Not network edition). By and large, it's gone
very well. I'm authenticating off an Win 2012 AD server for all accounts and it's been working flawlessly. One
issue regarding the Web Client versus Zimbra Desktop.. I've searched the forums and don't see
a previous post to this effect, so I apologize in advance if I'm redundant.

A small number of mailboxes on ZCS are marked "Hide in GAL". If a user is utilizing the web client, these
addresses to not appear in autocomplete or searches of the GAL. So far, so good.

However, for users of Zimbra Desktop 7.3.1 (13063), the addresses still appear in autocomplete and
through GAL searches in the Address Book tab. Is this a known problem?

It's not a killer of an issue, but it does result in emails being sent to administrative accounts my department
owns but does not monitor.. I've set up forwarding on the server to avoid delays in responding, but I'd
like to know if I've perhaps configured something wrong. Thoughts appreciated...


User avatar
DualBoot
Elite member
Elite member
Posts: 1073
Joined: Mon Apr 18, 2016 8:18 pm
Location: Earth
ZCS/ZD Version: ZCS FLOSS - 8.7.11 Mutli servers

Re: Hide from GAL not honored in Desktop?

Postby DualBoot » Thu Feb 21, 2019 2:33 pm

Hello,

if the Zimbra Desktop user use the webmail, does it behave in the same way ?

For information Zimbra Desktop is no more supported.

Regards,
kbrokaw
Posts: 5
Joined: Wed Feb 20, 2019 9:18 pm
Location: Maine, USA
ZCS/ZD Version: 8.8.10_GA_3716 CentOS 7

Re: Hide from GAL not honored in Desktop?

Postby kbrokaw » Thu Feb 21, 2019 2:54 pm

As I mentioned before, it is properly hidden if the web client is used.. it's only in Zimbra Desktop
that an account with Hide from GAL checked is still visible.

I wasn't aware that ZD wasn't supported at all anymore. Just migrated everyone off Outlook. Sigh.
User avatar
DualBoot
Elite member
Elite member
Posts: 1073
Joined: Mon Apr 18, 2016 8:18 pm
Location: Earth
ZCS/ZD Version: ZCS FLOSS - 8.7.11 Mutli servers

Re: Hide from GAL not honored in Desktop?

Postby DualBoot » Thu Feb 21, 2019 3:04 pm

for the first point, I was not sure, so this is why I asked.

Second point why migrate to another desktop client when the web one provides everything a user needs ?

Regards,
kbrokaw
Posts: 5
Joined: Wed Feb 20, 2019 9:18 pm
Location: Maine, USA
ZCS/ZD Version: 8.8.10_GA_3716 CentOS 7

Re: Hide from GAL not honored in Desktop?

Postby kbrokaw » Thu Feb 21, 2019 5:51 pm

I meant no disrespect.. I apologize if I sounded so.

I understand your question, but the web client is missing one important "feature" in the
eyes of the organization.. the ability to archive messages to the local system (and on
to storage which is on a separate, backed up server... we have to comply with discovery
laws). Therefore we do not store everything, old and new, on the production Zimbra server.

My choices were Zimbra Desktop or trying to shoehorn 3rd party CalDEV
and CarDEV add-ons into Outlook or Thunderbird. (I tried thunderbird with appropriate
add-ons, but had issues with stability). Having seen 3rd party products break all too often
in the past when Microsoft release an update (I've been doing this for 40 years.. actually
before Microsoft existed), I was hesitant to rely upon add-ons, since MS doesn't support
CalDAV up to and through Office 2016 (don't have 2019 yet, so I can't speak to that).

Honestly, I'm starting to see ample evidence that Zimbra Desktop has other flaws..
address book groups created through Desktop contain spurious entries when viewed
via the Web Client, sharing is wonky, etc. When I inquired about Zimbra, Synacor told
me that Zimbra Desktop was a viable solution.. apparently not. I'm trying to support
a county government for a very small rural county of only about 17,000 people.. they
don't have funds for commercial email solutions, so we went with the Zimbra Open
Source (non-commercial) version. Guess I have a lot more work to do.
phoenix
Ambassador
Ambassador
Posts: 26326
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Re: Hide from GAL not honored in Desktop?

Postby phoenix » Thu Feb 21, 2019 8:40 pm

IMO, you'd be far better with an archiving solution instead of trusting each user to correctly archive and keep their mail. There are free open source archiving solutions available the last time I did an internet search - why not have a look at that for a more 'professional' solution.
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
phoenix
Ambassador
Ambassador
Posts: 26326
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Re: Hide from GAL not honored in Desktop?

Postby phoenix » Thu Feb 21, 2019 8:43 pm

Here's a free one for starters: https://www.enkive.org/
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
kbrokaw
Posts: 5
Joined: Wed Feb 20, 2019 9:18 pm
Location: Maine, USA
ZCS/ZD Version: 8.8.10_GA_3716 CentOS 7

Re: Hide from GAL not honored in Desktop?

Postby kbrokaw » Thu Feb 21, 2019 9:28 pm

I understand, but I was asked why I didn't chose to use only the web client, hence
my response.. it seemed a good idea at the time. This is a small county government
with a small staff. The local archiving was being performed via a Zimlet. Now I have
to re-think the process if, as it seems, the Desktop app isn't functional. Just wish
I'd found that out a wee bit sooner.

Considering my budget for the setup was (and still is) $0 , this seemed like a good
solution at the time, and was even guided in that direction. I'll go back to square
one and work it out. The mail server is working flawlessly, as most postfix-based
ones tend to :-)

Return to “Error Reports”

Who is online

Users browsing this forum: No registered users and 1 guest