OPEN DRIVE BUTTON UNRESPONSIVE 8.8.15 NC 18 Zimbra drive 0.8.25 [SOLVED]

All about Zimbra Drive
Post Reply
Posts: 4
Joined: Thu Dec 31, 2020 7:08 pm

OPEN DRIVE BUTTON UNRESPONSIVE 8.8.15 NC 18 Zimbra drive 0.8.25 [SOLVED]

Post by subrednorte »

I have spent a whole week trying to make zimbra drive to work with fresh installation of zimbra open source 8.8.15.

At this time I'm using Zimbra 8.8.5 with Nexcloud V13 without problems and I'm migration to 8.8.15

First thing to note is that connection errors from zimbra server to nextcloud servers ARE NOT SHOWN AT USER SCREEN. Simply it does nothing, and you should debug using logs!!

First error is error 400: Bad Request. This is because authorized domains in nextcloud are configured in config.php with ip address of the server. Then I changed to nexcloud fqdn name.

Code: Select all

 'trusted_domains' =>
  array (
          0 => '',
          1 => ''
After solving this, now I have 500 error: Internal server error

I thought of compatibility problems, then I installed nextcloud V18, as there is no zimbradrive app for V20 that I was using. Then I installed zimbra drive app 0.8.25

In order to know what was going wrong I used http instead of https, and then I ran tcpdump to trace ip packets.

That is what I found:

Code: Select all

From zimbra to nextcloud:

09:21:12.566916 IP (tos 0x0, ttl 64, id 9139, offset 0, flags [DF], proto TCP (6), length 434) > Flags [P.], cksum 0x9a9f (incorrect -> 0x18df), seq 1:383, ack 1, win 229, options [nop,nop,TS val 956963885 ecr 3552137239], length 382: HTTP, length: 382
        POST /nextcloud/index.php/apps/zimbradrive/api/2.0/GetAllFolders HTTP/1.1
        Content-Length: 84
        Content-Type: application/x-www-form-urlencoded; charset=UTF-8
        Connection: Keep-Alive
        User-Agent: Apache-HttpClient/4.5.8 (Java/13.0.1)
        Accept-Encoding: gzip,deflate


nextcloud response:

09:21:12.667050 IP (tos 0x0, ttl 64, id 20412, offset 0, flags [DF], proto TCP (6), length 6110) > Flags [P.], cksum 0xb0cb (incorrect -> 0x2aa9), seq 1:6059, ack 383, win 235, options [nop,nop,TS val 3552137339 ecr 956963885], length 6058: HTTP, length: 6058
        HTTP/1.1 500 Internal Server Error
        Date: Fri, 15 Jan 2021 14:18:35 GMT
        Server: Apache/2.4.37 (centos) OpenSSL/1.1.1g
        X-Powered-By: PHP/7.2.24
        Expires: Thu, 19 Nov 1981 08:52:00 GMT
        Cache-Control: no-store, no-cache, must-revalidate
        Pragma: no-cache
                <body id="body-login">
                <div id="nojavascript">
                                This application requires JavaScript for correct operation. Please <a href="" target="_blank" rel="noreferrer noopener">enable JavaScript</a> and reload the page.            </div>
                                        <div class="wrapper">
                                <div class="v-align">
                                                                                <header role="banner">
                                                        <div id="header">
                                                                <div class="logo">
                                                                        <h1 class="hidden-visually">
                                                                                Nextcloud                                                               </h1>
                                                <div class="error error-wide">
                <h2>Internal Server Error</h2>
                <p>The server was unable to complete your request.</p>
                <p>If this happens again, please send the technical details below to the server administrator.</p>
                <p>More details can be found in the server log.</p>

This is shown at apache log

Code: Select all - - [15/Jan/2021:09:18:38 -0500] "POST /nextcloud/index.php/apps/zimbradrive/api/2.0/SearchRequest HTTP/1.1" 500 4616 "-" "Apache-HttpClient/4.5.8 (Java/13.0.1)"
I tried google chrome and firefox, both ot them with javascript enabled. How to enable javascript in the zimbra server?

No other error logs are found

Following this Subject, I uninstalled zimbra-chat and reinstalled zimbra-drive using dnf as I'm using Centos 8, but nothing works!!

Zimbra Drive is critical to our institution as we have very large files to share!!

Last edited by subrednorte on Tue Jan 19, 2021 1:23 pm, edited 1 time in total.
Posts: 4
Joined: Thu Dec 31, 2020 7:08 pm

Re: OPEN DRIVE BUTTON UNRESPONSIVE 8.8.15 NC 18 Zimbra drive 0.8.25 [SOLVED]

Post by subrednorte »


After some days of hard work I found the following using the "registers" option of the configuration page.

1- Bug that flooded de log:

"You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at /var/www/html/nextcloud/3rdparty/patchwork/utf8/src/Patchwork/Utf8/Bootup/intl.php#18"

This ocurred continuously

It caused error when trying to log into Nexcloud login page using zimbra LDAP

Solution: Install intl php module

2- Call to a member function inGroup()

This is the main bug.

Google directed me to this link

Here there are two options:

Downgrade NC to NC 17
Apply the temporary fix

file: in nextcloud/apps/zimbradrive/lib/auth/abstractzimbrausersbackend.php

Code: Select all

    protected function insertUserInGroup(User $user, $groupName)
            $targetGroup = $this->groupManager->get($groupName);
Advanced member
Advanced member
Posts: 80
Joined: Sat Feb 04, 2023 4:40 pm
ZCS/ZD Version: 8.8.15.GA.4179.UBUNTU20.64

Re: OPEN DRIVE BUTTON UNRESPONSIVE 8.8.15 NC 18 Zimbra drive 0.8.25 [SOLVED]

Post by saifulslm09 »


I have the same zimbra, NC and zimbra drive version. I am still stuck in the zimbra drive tab from zimbra web. This zimbra drive tab is unresponsive.

I already tried the fix you mentioned nextcloud/apps/zimbradrive/lib/auth/abstractzimbrausersbackend.php.

How do you start debug mode. Where to do it?

Are you still using the same version of NC and zimbra drive?
Post Reply