Usually receive emails as plain text although it was sent as HTML and the HTML mail display is on

General discussion about Zimbra Desktop.
Post Reply
Jaybkit
Posts: 2
Joined: Tue Mar 06, 2018 6:01 pm

Usually receive emails as plain text although it was sent as HTML and the HTML mail display is on

Post by Jaybkit »

Hi every one,

I am facing this problem recently and I did everything to fix but no result.

This problem started with one sender and now almost 80% emails have this problem. I received them as plain text, no picture, no table, no color... I am sure that it was sent as HTML (checked). I also use Outlook for Mac OS (2016). All attachments in Outlook had been converted to winmail.dat that I can not open. I have to open Zimbra Desktop to download.

I tried to change my settings but everything works well. The display mail is as HTML (when possible). I chose everything to be displayed as HTML but my incoming emails still do not change.

I hope that someone has been in this situation can help me. I can not go to the support portal because my company will take forever to help me. I would glad if someone can raise this to technicians of Zimbra.

Thank you very much!

Long Le.
budy
Posts: 26
Joined: Sat Sep 13, 2014 2:07 am

Re: Usually receive emails as plain text although it was sent as HTML and the HTML mail display is on

Post by budy »

Have you verified, that in Settings -> General -> Mail the option "Show mails as HTML (if possible)" is checked? Also, ask your ZCS server admin, if this setting has somewhat be changed in your account settings on the server. Or rather, have it unchecked, saved and checked again. We did experience somethig somewhat similar, where the advanced search vanished from some colleagues ZD. After disableling/enabling that in the user account through Zimbra Admin, it came back.

Cheers,
budy
Jaybkit
Posts: 2
Joined: Tue Mar 06, 2018 6:01 pm

Re: Usually receive emails as plain text although it was sent as HTML and the HTML mail display is on

Post by Jaybkit »

Hi budy,

Thank you for your reply. I have checked "Display mail as HTML (when possible)" but it did not help. Can you explain more about the Zimbra admin?
yasanthau
Advanced member
Advanced member
Posts: 57
Joined: Sat Sep 13, 2014 12:52 am

Re: Usually receive emails as plain text although it was sent as HTML and the HTML mail display is on

Post by yasanthau »

I also have the same issue. Received emails are shown as below. No matter whether it is webmail or client like Outlook. Appreciate an urgent feedback. Many users (not all users) are having the same issue. Deleting and re-creating the user also did not help. Zimbra version is "Release 8.8.9_GA_3019.RHEL7_64_20180809160254 RHEL7_64 FOSS edition, Patch 8.8.9_P4"
Capture.PNG
Capture.PNG (89.67 KiB) Viewed 123320 times
tamarteleco
Posts: 3
Joined: Fri Oct 04, 2019 3:13 pm

Re: Usually receive emails as plain text although it was sent as HTML and the HTML mail display is on

Post by tamarteleco »

did you find a solution?
User avatar
vnngoanhtuan
Posts: 9
Joined: Wed Feb 20, 2019 8:44 am

Re: Usually receive emails as plain text although it was sent as HTML and the HTML mail display is on

Post by vnngoanhtuan »

Hi Pro,

- I having the same problem with zimbra 8.8.15 x64 on CentOS 7.x x64
- An email is sent to two accounts of the same domain and with the same COS default settings, one account receives the email in html correctly, but the other receives an attachment with the message attachment and the inscription "Unknown <text / html> "
- The settings of the two accounts are for display in html In the Preferences >> E-mail >> Message View tab, please help!

Thanks,
Tuan Ngo
ozer44
Posts: 9
Joined: Wed Jun 26, 2019 7:14 pm

Re: Usually receive emails as plain text although it was sent as HTML and the HTML mail display is on

Post by ozer44 »

vnngoanhtuan wrote:Hi Pro,

- I having the same problem with zimbra 8.8.15 x64 on CentOS 7.x x64
- An email is sent to two accounts of the same domain and with the same COS default settings, one account receives the email in html correctly, but the other receives an attachment with the message attachment and the inscription "Unknown <text / html> "
- The settings of the two accounts are for display in html In the Preferences >> E-mail >> Message View tab, please help!

Thanks,
Tuan Ngo
Hi Tuan,

I have a same issue, did you find a solution?
User avatar
vnngoanhtuan
Posts: 9
Joined: Wed Feb 20, 2019 8:44 am

Re: Usually receive emails as plain text although it was sent as HTML and the HTML mail display is on

Post by vnngoanhtuan »

Dear @ozer44,

Trusted Addresses/Domains will be solved this issues.

Thanks,
Tuan Ngo
wgate
Posts: 2
Joined: Mon Jun 05, 2023 4:45 pm

Re: Usually receive emails as plain text although it was sent as HTML and the HTML mail display is on

Post by wgate »

I first noticed this problem when adding attachments in Standard HTML Mode not Ajax but also noticed it did the same thing to my signature when sending with Ajax adding in div html and break br html in the signature. So both Ajax and HTML mode can be affected once corrupted.

Fix: Use Advanced Ajax mode go to preferences mail and check Display as plain text save then check as HTML and save. Scroll down and check compose as text save and then compose as HTML and save.

This may not work as a user so login to the Zimbra Admin go the account preferences for the affected email. Uncheck View Mail as HTML when possible Save, then recheck view mail as HTML and Save. Scroll down to Composing Mail and change the select box to always compose as text and Save. Then change it to always compose as HTML and Save.

Relogin to your account that is in Advanced Ajax mode and all should be fixed. If you switch back to HTML mode the problem will appear again and you'll have to switch back to Ajax and repeat the steps above again.

Running as Ubuntu VM with bhyve on FreeBSD
Release 8.8.15.GA.4179.UBUNTU20.64 UBUNTU20_64 FOSS edition, Patch 8.8.15_P40.

sjohn/wgate
Post Reply