SSL error for muliple domain while connecting from outlook

Ask your questions and get help with Zimbra's Outlook Connector.
Post Reply
pravesh
Posts: 6
Joined: Mon Aug 17, 2020 3:24 pm

SSL error for muliple domain while connecting from outlook

Post by pravesh »

Hi,
Need some help on this:

I have a zimbra with multiple domains (email for multiple domains i.e mail.abc.com, mail.xyz.com, mail.example.com, mail.test.com).
I have installed commercial SSL for all my email domain.
Among multiple email domains my one email domain is not needed and its SSL is also not renewed. lets say mail.test.com is not needed and its ssl is not renewed.
Now issue is with connecting outlook to mail.abc.com and mail.xyz.com with imap 993 and smpt with 587.
While browsing email in web all are working fine and SSL is showed correctly green in browser with respective domain SSL certificate.

But while connecting from outlook and mobile devices for mail.abc.com, mail.xyz.com, mail.example.com I am getting error for ssl as certificate is expired and couldn't connect to email as its taking SSL which is expired one for mail.test.com

My Zimbra version is Zimbra 8.8.12_GA_3794 (build 20190329045002).
User avatar
zimico
Outstanding Member
Outstanding Member
Posts: 225
Joined: Mon Nov 14, 2016 8:03 am
Location: Vietnam
ZCS/ZD Version: 8.8.15 P3
Contact:

Re: SSL error for muliple domain while connecting from outlook

Post by zimico »

Hi,
I use Letsencrypt for multidomain/single server and do not have this issue. However, I believe that you should follow this wiki: https://wiki.zimbra.com/wiki/Multiple_S ... _for_HTTPS

Regards,
Minh.
pravesh
Posts: 6
Joined: Mon Aug 17, 2020 3:24 pm

Re: SSL error for muliple domain while connecting from outlook

Post by pravesh »

Hi zimico,

While browsing in web even I do not have issue all are working fine. Issue with connecting from client like outlook.

Provided link not browsed.
pravesh
Posts: 6
Joined: Mon Aug 17, 2020 3:24 pm

Re: SSL error for muliple domain while connecting from outlook

Post by pravesh »

Hi there,

Any one to help me?
lowhigh
Posts: 36
Joined: Wed Feb 08, 2017 5:14 pm

Re: SSL error for muliple domain while connecting from outlook

Post by lowhigh »

I have the same problem while using multiple SSL for Multiple Domain (SNI)

Outlook always recoginze 1 SSL Cer for all of domain, such as i have 2 domain configed with mail.abc.com and mail.xyz.com

When config Outlook with email @abc.com, incoming server and outgoing server is mail.abc.com but outlook always show Certificate Notification "The server you are connected is using a security certificate that can not be verified " and when browse this SSL Cert, it points to SSL of mail.xyz.com

Please tell me how to fix it!
User avatar
maumar
Outstanding Member
Outstanding Member
Posts: 389
Joined: Fri Sep 12, 2014 10:28 pm

Re: SSL error for muliple domain while connecting from outlook

Post by maumar »

use case

on fresh Daffodil you configure 2 vhosts
mail.aaaa.com
mail.bbb.com

then you configure an account w/ tb or outllok on domain mail.bbb.com
but zimbra send always mail.aaaa.com certificate
and tb / outlok complain cert does not belong to mail.bbb.com

workaround: swtch mail.aaa.com and mail.bbb.com on nginx.conf.mail.imaps
this is a bug according to me

vi nginx.conf.mail.imaps


# IMAPS proxy configuration
#


server
{
server_name mail.bbb.com;
#listen 993 ipv6only=off ssl;
listen 993 ssl;
#listen 993 ssl;
protocol imap;
proxy on;
timeout 60;
proxy_timeout 2100;
ssl_certificate /opt/zimbra/conf/domaincerts/mail.bbb.com.crt;
ssl_certificate_key /opt/zimbra/conf/domaincerts/mail.bbb.com.key;
sasl_service_name "imap";
}


server
{
server_name mail.aaaa.com;
#listen 993 ipv6only=off ssl;
listen 993 ssl;
#listen 993 ssl;
protocol imap;
proxy on;
timeout 60;
proxy_timeout 2100;
ssl_certificate /opt/zimbra/conf/domaincerts/mail.aaaa.com.crt;
ssl_certificate_key /opt/zimbra/conf/domaincerts/mail.aaaa.com.key;
sasl_service_name "imap";
}
Klug
Ambassador
Ambassador
Posts: 2726
Joined: Mon Dec 16, 2013 11:35 am
Location: France - Drôme
ZCS/ZD Version: All of them
Contact:

Re: SSL error for muliple domain while connecting from outlook

Post by Klug »

Could be ZBUG-3125, that is supposed to be fixed in the next patch.
https://wiki.zimbra.com/wiki/Multiple_S ... own_Issues
Post Reply