Problem instalation zimbra Failed to start slapd

Ask questions about your setup or get help installing ZCS server (ZD section below).
carias78
Posts: 3
Joined: Sat Sep 13, 2014 1:05 am

Problem instalation zimbra Failed to start slapd

Postby carias78 » Tue Mar 09, 2010 11:45 am

Help, I have the problem in the instalation de the zimbra, the error is:
zimbra@mail:~$ ldap start
Failed to start slapd. Attempting debug start to determine error.

daemon: bind(7) failed errno=98 (Address already in use)

slap_open_listener: failed on ldap://mail:389


phoenix
Ambassador
Ambassador
Posts: 26414
Joined: Fri Sep 12, 2014 9:56 pm
Location: Liverpool, England

Problem instalation zimbra Failed to start slapd

Postby phoenix » Thu Mar 18, 2010 9:20 am

This is actually in the wrong forum, I'll move it.
[quote user="carias78"]Help, I have the problem in the instalation de the zimbra, the error is:
zimbra@mail:~$ ldap start
Failed to start slapd. Attempting debug start to determine error.

daemon: bind(7) failed errno=98 (Address already in use)

slap_open_listener: failed on ldap://mail:389[/QUOTE]It's probably the same reason that usually applies to this problem, you don't have valid A & MX records and/or a valid /etc/hosts file.
Post the output of the following commands (run on the Zimbra server):
cat /etc/hosts

cat /etc/resolv.conf

dig yourdomain.com any

dig yourdomain.com mx

host `hostname`
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
carias78
Posts: 3
Joined: Sat Sep 13, 2014 1:05 am

Problem instalation zimbra Failed to start slapd

Postby carias78 » Thu Mar 18, 2010 9:56 am

[quote user="carias78"]Help, I have the problem in the instalation de the zimbra, the error is:
zimbra@mail:~$ ldap start
Failed to start slapd. Attempting debug start to determine error.

daemon: bind(7) failed errno=98 (Address already in use)

slap_open_listener: failed on ldap://mail:389[/QUOTE]

hi, output of the following commands
root@mail:~# cat /etc/hosts

127.0.0.1 localhost.localdomain localhost

172.19.143.2 mail.banpro2.com.ve mail


# The following lines are desirable for IPv6 capable hosts

::1 ip6-localhost ip6-loopback

fe00::0 ip6-localnet

ff00::0 ip6-mcastprefix

ff02::1 ip6-allnodes

ff02::2 ip6-allrouters

ff02::3 ip6-allhosts

root@mail:~#

root@mail:~#

root@mail:~# cat /etc/resolv.conf

### BEGIN INFO

#

# Modified_by: NetworkManager

# Process: /usr/bin/NetworkManager

# Process_id: 4928

#

### END INFO
nameserver 172.19.143.2

#search mail.banpro2.com.ve
#nameserver 200.35.65.3

#nameserver 200.35.65.4

root@mail:~#

root@mail:~#

root@mail:~# dig banpro2.com.ve any
; <<>> DiG 9.4.2-P2.1 <<>> banpro2.com.ve any

;; global options: printcmd

;; Got answer:

;; ->>HEADER<
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 1
;; QUESTION SECTION:

;banpro2.com.ve. IN ANY
;; ANSWER SECTION:

banpro2.com.ve. 604800 IN SOA banpro2.com.ve. root.banpro2.com.ve. 1 604800 86400 2419200 604800

banpro2.com.ve. 604800 IN NS banpro2.com.ve.

banpro2.com.ve. 604800 IN A 172.19.143.2

banpro2.com.ve. 604800 IN MX 0 banpro2.com.ve.
;; ADDITIONAL SECTION:

banpro2.com.ve. 604800 IN A 172.19.143.2
;; Query time: 43 msec

;; SERVER: 172.19.143.2#53(172.19.143.2)

;; WHEN: Thu Mar 18 10:21:43 2010

;; MSG SIZE rcvd: 135
root@mail:~#

root@mail:~#

root@mail:~# dig banpro2.com.ve mx
; <<>> DiG 9.4.2-P2.1 <<>> banpro2.com.ve mx

;; global options: printcmd

;; Got answer:

;; ->>HEADER<
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1
;; QUESTION SECTION:

;banpro2.com.ve. IN MX
;; ANSWER SECTION:

banpro2.com.ve. 604800 IN MX 0 banpro2.com.ve.
;; AUTHORITY SECTION:

banpro2.com.ve. 604800 IN NS banpro2.com.ve.
;; ADDITIONAL SECTION:

banpro2.com.ve. 604800 IN A 172.19.143.2
;; Query time: 0 msec

;; SERVER: 172.19.143.2#53(172.19.143.2)

;; WHEN: Thu Mar 18 10:21:57 2010

;; MSG SIZE rcvd: 78
root@mail:~#

root@mail:~#


root@mail:~# host mail.banpro2.com.ve

mail.banpro2.com.ve is an alias for banpro2.com.ve.

banpro2.com.ve has address 172.19.143.2

banpro2.com.ve mail is handled by 0 banpro2.com.ve.

root@mail:~#
User avatar
quanah
Zimbra Alumni
Zimbra Alumni
Posts: 1667
Joined: Fri Sep 12, 2014 10:33 pm
Contact:

Problem instalation zimbra Failed to start slapd

Postby quanah » Thu Mar 18, 2010 12:05 pm

The error messages clearly states that LDAP was unable to start because something else is already using the LDAP port (389). Determine what that is and disable it.
--
Quanah Gibson-Mount
Product Architect, Symas http://www.symas.com/
OpenLDAP Core team http://www.openldap.org/project/
carias78
Posts: 3
Joined: Sat Sep 13, 2014 1:05 am

Problem instalation zimbra Failed to start slapd

Postby carias78 » Thu Mar 18, 2010 12:28 pm

[quote user="quanah"]The error messages clearly states that LDAP was unable to start because something else is already using the LDAP port (389). Determine what that is and disable it.[/QUOTE]
this is the por open:
root@mail:~# netstat -plut

Conexiones activas de Internet (solo servidores)

Protocolo Recv-Q Send-Q Dirección Local Dirección Externa Estado PID/Program name

tcp 0 0 *:ldap *:* ESCUCHAR 5016/slapd

tcp 0 0 mail.banpro2.com:domain *:* ESCUCHAR 4953/named

tcp 0 0 localhost.locald:domain *:* ESCUCHAR 4953/named

tcp 0 0 localhost.localdoma:ipp *:* ESCUCHAR 5058/cupsd

tcp 0 0 localhost.localdoma:953 *:* ESCUCHAR 4953/named

tcp6 0 0 [::]:ldap [::]:* ESCUCHAR 5016/slapd

tcp6 0 0 [::]:domain [::]:* ESCUCHAR 4953/named

tcp6 0 0 [::]:ssh [::]:* ESCUCHAR 4979/sshd

tcp6 0 0 ip6-localhost:953 [::]:* ESCUCHAR 4953/named

udp 0 0 *:domain *:* 4953/named

udp 0 0 mail.banpro2.com:domain *:* 4953/named

udp 0 0 localhost.locald:domain *:* 4953/named

udp 0 0 *:47711 *:* 5000/avahi-daemon:

udp 0 0 *:mdns *:* 5000/avahi-daemon:

udp6 0 0 [::]:34459 [::]:* 4953/named

udp6 0 0 [::]:domain [::]:* 4953/named

root@mail:~#
malayo
Advanced member
Advanced member
Posts: 116
Joined: Sat Sep 13, 2014 1:59 am

Problem instalation zimbra Failed to start slapd

Postby malayo » Sun Nov 25, 2012 12:40 am

just as a note if someone else is having this issue, my solution is to check stop zimbra services with zmcontrol stop and then look for any running zimbra services (amavisd, clamd, memcached etc.) with netstat -tulnp | grep LISTEN, kill it with killall
msmollin
Posts: 1
Joined: Mon Mar 16, 2015 11:23 am

Problem instalation zimbra Failed to start slapd

Postby msmollin » Mon Mar 16, 2015 11:41 am

I ran into this issue upgrading from 8.0.9 -> 8.6.0 on Ubuntu 12.04 LTS-5. My server install dates back to 7.1.4_GA on Ubuntu 10.04 to give some background, so there is some upgrade cruft. One of those pieces of cruft (i think) was that /opt/zimbra/bin/ldap was looking for the PID file in /opt/zimbra/data/ldap/state/run/slapd.pid but the LDAP server's config (cn=config.ldif) was putting it in/opt/zimbra/openldap/var/run/slapd.pid.



After some research, it appears the script's path is correct, so I updated the LDAP server's config file to match, and /opt/zimbra/libexec/zmsetup.pl (which is what generates this error) was happy as a clam.



One thing of note - the install.sh script for 8.6.0 merely calls /opt/zimbra/libexec/zmsetup.pl at the end of the install setup, so it's safe to re-run this command if it fails and thus having to reinstall all of 8.6.0.

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 3 guests