Error on attempt to read email

Ask questions about your setup or get help installing ZCS server (ZD section below).
Posts: 1
Joined: Fri Sep 12, 2014 10:28 pm

Error on attempt to read email

Postby iroc » Mon Mar 12, 2007 6:04 pm

Current status: I can download my pop3 email from an exchange server and see the listing of messages but I get an error when I attempt to open an individual message (error message below).
System Configuration:
Base Install from provided VMware image. Used the Rpath update tool to update system. (I did have an error at the end saying invalid permissions on log file, chmoded 666 and was okay).
I created a user account and logged in, setup pop3 mail retrieval and received all my headers. (woohoo! I thought, as on my previous install I had UID case problems that I tried to manually setup). This is where the problem kicks in, I get an error when I try to open an email :

msg - system failure: java.lang.NoSuchMethodError: com.zimbra.cs.mailbox.MessageCache.getMimeMessage(Lcom/zimbra/cs/mailbox/Message;Z)Ljavax/mail/internet/MimeMessage;

com.zimbra.common.service.ServiceException: system failure: java.lang.NoSuchMethodError: com.zimbra.cs.mailbox.MessageCache.getMimeMessage(Lcom/zimbra/cs/mailbox/Message;Z)Ljavax/mail/internet/MimeMessage;

at com.zimbra.common.service.ServiceException.FAILURE(

at com.zimbra.soap.SoapEngine.dispatchRequest(

at com.zimbra.soap.SoapEngine.dispatch(

at com.zimbra.soap.SoapEngine.dispatch(

at com.zimbra.soap.SoapServlet.doPost(

at javax.servlet.http.HttpServlet.service(

at com.zimbra.cs.servlet.ZimbraServlet.service(

at javax.servlet.http.HttpServlet.service(

at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(

at org.apache.catalina.core.ApplicationFilterChain.doFilter(

at org.apache.catalina.core.StandardWrapperValve.invoke(

at org.apache.catalina.core.StandardContextValve.invoke(

at org.apache.catalina.core.StandardHostValve.invoke(

at org.apache.catalina.valves.ErrorReportValve.invoke(

at org.apache.catalina.core.StandardEngineValve.invoke(

at org.apache.catalina.valves.AccessLogValve.invoke(

at org.apache.catalina.connector.CoyoteAdapter.service(

at org.apache.coyote.http11.Http11Processor.process(

at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(



at org.apache.tomcat.util.threads.ThreadPool$


Caused by: java.lang.NoSuchMethodError: com.zimbra.cs.mailbox.MessageCache.getMimeMessage(Lcom/zimbra/cs/mailbox/Message;Z)Ljavax/mail/internet/MimeMessage;

at com.zimbra.cs.mailbox.Message.getMimeMessage(

at com.zimbra.cs.mailbox.Message.getMimeMessage(

at com.zimbra.cs.service.mail.ToXML.encodeMessageAsMP(

at com.zimbra.cs.service.mail.Search.addMessageHit(

at com.zimbra.cs.service.mail.SearchConv.putHits(

at com.zimbra.cs.service.mail.SearchConv.handle(

at com.zimbra.soap.SoapEngine.dispatchRequest(

... 21 more
code - service.FAILURE

method - ZmCsfeCommand.prototype.invoke

detail - soap:Receiver

Elite member
Elite member
Posts: 2091
Joined: Fri Sep 12, 2014 9:53 pm

Error on attempt to read email

Postby marcmac » Tue Mar 13, 2007 11:55 pm

sounds like your install is missing some jar files. Could be from the upgrade, or something else - I assume you've tried restarting/rebooting?

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 3 guests