Outlook sync client

Ask your questions and get help with Zimbra's Outlook Connector.
bjquinn
Advanced member
Advanced member
Posts: 179
Joined: Fri Sep 12, 2014 10:00 pm

Outlook sync client

Postby bjquinn » Wed Mar 24, 2010 6:31 pm

I'm getting the same problem as some others here, when I try to add a sync source I get an error in the funamboladmin I get "bad version number in class file".
I have funambol 8.0.2, ZimbraConnector 0.6.02, Centos 5.4. After trying several of the Javas that came with Centos, I updated to jre1.6.0_18 from Sun's website. I'm using funamboladmin on the Centos box, not a Windows box.
Recognizing that this error is supposed to be a problem with funambol and funamboladmin not using the same version of Java, I edited the /opt/Funambol/bin/funambol script and added to the top -
export JAVA_HOME=/usr/java/jre1.6.0_18
I then edited /opt/Funambol/admin/bin/funamboladmin and added to the top -
jdkhome="/usr/java/jre1.6.0_18"
Still the same problem when I try to add a sync source on the ZimbraConnector. Anyone know what I'm missing?


6233maxxer
Outstanding Member
Outstanding Member
Posts: 391
Joined: Sat Sep 13, 2014 12:06 am

Outlook sync client

Postby 6233maxxer » Thu Mar 25, 2010 3:26 am

A friend of mine had similar error like the latest ones posted here. It was a problem of the ZimbraConnector. I gave him my (old) version and it worked.
I'm attaching it here, you can give it a try...

ZimbraConnector_2009.zip

bjquinn
Advanced member
Advanced member
Posts: 179
Joined: Fri Sep 12, 2014 10:00 pm

Outlook sync client

Postby bjquinn » Thu Mar 25, 2010 11:54 am

Thanks! I couldn't get the one you attached to work, but your post combined with some comments I saw in some other posts caused me to try ZimbraConnector 0.5.02, which appears to work.
Maybe ZimbraConnector 0.6.x is intended for the upcoming Funambol 8.5 or something?
bjquinn
Advanced member
Advanced member
Posts: 179
Joined: Fri Sep 12, 2014 10:00 pm

Outlook sync client

Postby bjquinn » Thu Mar 25, 2010 5:04 pm

Let me rephrase that - I found Zoltan's version of the 0.5.02 connector, that that worked. Was getting some 511 errors otherwise when trying to sync.
Is anyone maintaining this connector? I saw somewhere that maybe the original developer may have disappeared?
dkbk
Advanced member
Advanced member
Posts: 67
Joined: Sat Sep 13, 2014 12:32 am

Outlook sync client

Postby dkbk » Tue Jun 01, 2010 6:00 pm

Edit : Solved my Error 700 in Outlook Sync Client. My server setup was ok but I needed to add /funambol/ds after the server URL in the outlook sync client for it to work properly.
Overall, getting this working was MUCH simpler than I expected with the great guides and tips from everyone although I have yet to test it on the BB side.
I also have a question. Is it possible to force sync only one-way ? For example, erase all data on the phone and then sync from zimbra ?
Is it also possible to sync two zimbra servers with funambol ? I'd think it'd be possible but I haven't seen any attempts to do this yet.
Edit 2 : Another edit! I spoke too quickly.
I started testing with a handheld my carrier lent me for testing today and I created a dummy account where I imported my own caldendar, contacts and created a few dummy tasks.
Contacts seem to work fine. They're mostly just e-mails at this point but everyone seems in order.
Calendaring however is an issue. All calendars imported on the date of december 31st 1969 and at the same hour. So I have 1006 appointments at the same hour. I'll be busy. This *might* be due to the fact that zimbra seems to have imported my calendar as invitations and not like regular events however I had created 10 or so future events for playing with and they didn't show up at their intended date either. I seem to recall a user in this thread with a similar issue but a search didn't locate the person in question. Any idea what's going on ?
Tasks are also an issue. The proper amount of tasks transfer but they're empty. No name, no date, nothing. That's also obviously an issue.
I'm at a loss to explain what's happening here as the transfers did happen but don't work as they should.
Edit 3 : Found the beggining of a solution here :
Seems">https://core.forge.funambol.org/ds/viewMessage.do?dsForumId=405&dsMessageId=62002
Seems
we have to specify that BB'S use b64 in funambol (I really wish there was better documentation on the funambol side on how to install and configure the BB PIM Bundle as I had to dig through obscure forums to get the info).
However, when I go into the DataTansformation Manager in the admin tool and try to ad b64 to the relevant dataset, I get the following error :
java.lang.NullPointerException

at com.funambol.admin.settings.panels.DataTransformerManagerTableModel.setValueAt(DataTransformerManagerTableModel.java:189)

at javax.swing.JTable.setValueAt(Unknown Source)

at javax.swing.JTable.editingStopped(Unknown Source)

at javax.swing.AbstractCellEditor.fireEditingStopped(Unknown Source)

at javax.swing.DefaultCellEditor$EditorDelegate.stopCellEditing(Unknown Source)

at javax.swing.DefaultCellEditor.stopCellEditing(Unknown Source)

at javax.swing.JTable$GenericEditor.stopCellEditing(Unknown Source)

at javax.swing.plaf.basic.BasicTableUI$Handler.mousePressed(Unknown Source)

at java.awt.AWTEventMulticaster.mousePressed(Unknown Source)

at java.awt.Component.processMouseEvent(Unknown Source)

at javax.swing.JComponent.processMouseEvent(Unknown Source)

at java.awt.Component.processEvent(Unknown Source)

at java.awt.Container.processEvent(Unknown Source)

at java.awt.Component.dispatchEventImpl(Unknown Source)

at java.awt.Container.dispatchEventImpl(Unknown Source)

at java.awt.Component.dispatchEvent(Unknown Source)

at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)

at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)

at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)

at java.awt.Container.dispatchEventImpl(Unknown Source)

at java.awt.Window.dispatchEventImpl(Unknown Source)

[catch] at java.awt.Component.dispatchEvent(Unknown Source)

at java.awt.EventQueue.dispatchEvent(Unknown Source)

at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)

at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)

at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at java.awt.EventDispatchThread.run(Unknown Source)


Any idea what's going on ?
I'll continue my search for now.
Edit 4 (and final hopefully!) : For some reason, editing the existing field yielded an error and I found a post similar enough on these boards (http://www.zimbra.com/forums/mobility/37315-solved-funambol-blackberry-calendar-syncing.html) that led me to try to create new entries with the same names and it worked. I'll leave my wall of text here in the hopes it can help someone else avoid all these issues.
I also realized GAL wasn't syncing previously. Hopefully this will fix it now.
erroneus
Posts: 4
Joined: Sat Sep 13, 2014 1:17 am

Outlook sync client

Postby erroneus » Fri Jun 18, 2010 1:33 pm

There is a LOT of reading and catching up to do in here. I am brand new to Zimbra and Funambol. I am not new to CentOS and not new to the command line and other Linux gynmastics. But before I commit myself to concentrating on all of this stuff, I would like to ask the simple (and likely most repeated) question:
What combination of CentOS 5.5 64 bit and Zimbra v6.0.7 works best with what version of Funambol and Funambol connector? Following up with that, how do I make it work?
So far, I have CentOS 5.5 64bit working with Zimbra v6.0.7. I have installed the latest Funambol onto that machine and the process is working to the extent that I was able to point my Blackberry to the URL of the server as indicated by Funambol and have it sync the address book on my phone. Funambol is not yet connected with Zimba, however. And given the size of this thread, I fear that it must be extremely difficult or maybe even impossible.
I believe my combination is likely the most common so I am hoping there will be a common answer to making it work.
cbnidk
Posts: 24
Joined: Sat Sep 13, 2014 12:55 am

Outlook sync client

Postby cbnidk » Sat Jul 31, 2010 4:40 pm

[quote user="erroneus"]There is a LOT of reading and catching up to do in here. I am brand new to Zimbra and Funambol. I am not new to CentOS and not new to the command line and other Linux gynmastics. But before I commit myself to concentrating on all of this stuff, I would like to ask the simple (and likely most repeated) question:
What combination of CentOS 5.5 64 bit and Zimbra v6.0.7 works best with what version of Funambol and Funambol connector? Following up with that, how do I make it work?
So far, I have CentOS 5.5 64bit working with Zimbra v6.0.7. I have installed the latest Funambol onto that machine and the process is working to the extent that I was able to point my Blackberry to the URL of the server as indicated by Funambol and have it sync the address book on my phone. Funambol is not yet connected with Zimba, however. And given the size of this thread, I fear that it must be extremely difficult or maybe even impossible.
I believe my combination is likely the most common so I am hoping there will be a common answer to making it work.[/QUOTE]
Hi
It is working I have it runing on a ubuntu 8.04.4 64 bit with zimbra 6.0.7 64 bit and funambol 64 bit you have to follow this guide

Open Source Mobile Calendar and Contact Synchronization - Zimbra :: Wiki
if you do it right it will work
I think it is not a problem you use centos as the host

when you make the zimbraConnector cal and other sync you have to http ://host:8080/service/soap/ dont use https you can run in some problem, use you that port you have http funambol running on

if it is on the same server you don't have to use
you">https
you
allso have to see this

For Funambol 8.x, you will need to download the ZimbraConnector.zip released by Zoltan67, and attached to his post in the Zimbra + Funambol Sync4j Code.
you also have to use the same java ver. for zimbra funambol and funambol admin, I use zimbra jave for funambol and on a xp I have jave ver. 1.6.0_16 like the one on zimbra 6.0.7 for funambol admin
I have ssl on the funambol install and I can make a ssl sync from mobile, you have to install the certificate from funambol on the phone I have a wm 6.5
claus
ict4schools
Posts: 9
Joined: Sat Sep 13, 2014 12:43 am

Outlook sync client

Postby ict4schools » Mon Aug 02, 2010 2:49 am

[quote user="cbnidk"]...
you allso have to see this

For Funambol 8.x, you will need to download the ZimbraConnector.zip released by Zoltan67, and attached to his post in the Zimbra + Funambol Sync4j Code.
...

[/QUOTE]
That part is not true. To work with Funambol 8.x you can use the sourceforge one (https://sourceforge.net/projects/zimbrafunambol). That one is already updated to be working with Funambol 8.x. If not, I can patch it and make it work, because I have commit access to the project on the sourceforge page. So please use the sourceforge version and not the attached version by Zoltan67. Although he has a working patch, it's not yet up to date anymore and the original version is working again.
If by any means that version is not working in with your JAVA version, please post a bugreport at sourceforge, with the java version, kernel version and architecture. I get emailed with bugreports from sourceforged, but not always emailed on the posts on this forum.
So the output of the following commands:

[QUOTE]

uname -a

java -version

cat /opt/Funambol/bin/funambol-server

lsb_release -a (if that command is working)

[/QUOTE]
cbnidk
Posts: 24
Joined: Sat Sep 13, 2014 12:55 am

Outlook sync client

Postby cbnidk » Mon Aug 02, 2010 11:47 am

[quote user="ict4schools"]That part is not true. To work with Funambol 8.x you can use the sourceforge one (https://sourceforge.net/projects/zimbrafunambol). That one is already updated to be working with Funambol 8.x. If not, I can patch it and make it work, because I have commit access to the project on the sourceforge page. So please use the sourceforge version and not the attached version by Zoltan67. Although he has a working patch, it's not yet up to date anymore and the original version is working again.
If by any means that version is not working in with your JAVA version, please post a bugreport at sourceforge, with the java version, kernel version and architecture. I get emailed with bugreports from sourceforged, but not always emailed on the posts on this forum.
So the output of the following commands:[/QUOTE]


in jan 2010 I try it and I don't get it to work, that why.

I have in july 2010 reinstall

my zimbra but I don't try sourceforge ver. but maybe I will try it now

I think you have to make a note on sourceforge it will work with 8,x

now it is 8.7.0
my servwer

Linux zimbra 2.6.24-26-server #1 SMP Tue Dec 1 18:26:43 UTC 2009 x86_64 GNU/Linux

java version "1.6.0_16"

Java(TM) SE Runtime Environment (build 1.6.0_16-b01)

Java HotSpot(TM) 64-Bit Server VM (build 14.2-b01, mixed mode)

funambol 8.7.0 64 bit

zimbra 6.0.7 64 bit
Claus
dkbk
Advanced member
Advanced member
Posts: 67
Joined: Sat Sep 13, 2014 12:32 am

Outlook sync client

Postby dkbk » Tue Dec 07, 2010 8:31 am

This might be a bit premature but has anybody tested the blackberry sync setup with the new zcs 7 beta yet ?
What was the outcome ?
I'd love to test it myself but I don't currently have a spare server to run my tests on.

Return to “Zimbra Connector for Outlook”

Who is online

Users browsing this forum: No registered users and 1 guest