Trouble Migrating and Upgrading

Looking to migrate to ZCS? Ask here. Got a great tip or script that helped you migrate? Post it here.
j.mc
Posts: 13
Joined: Fri Sep 12, 2014 11:27 pm

Trouble Migrating and Upgrading

Postby j.mc » Mon Jun 09, 2008 2:46 pm

Hi all! New memeber and New to Zimbra!!
I am trying to migrate from an old server to a new server. I have installed Zimbra 5.0.6 on the new server with no problems. I was able to send mail from it and create accounts. The old server has 4.5.10 on it and is currently in production. I have tarballed the /opt/zimbra folder of the old server and moved it to the new server and extracted it over the top of the /opt/zimbra folder there. I then run the ./install.sh and perform an upgrade. Everything seems to go smooth and it seems like it knows I am going from 4.5.10 to 5.0.6 even though 5.0.6 is installed when I upgrade. The upgrade procedure then gives me :

Failed to start slapd. Attempting debug start to determine error.

daemon: bind(7) failed errno=99 (Cannot assign requested address)

slap_open_listener: failed on ldap://server.domain.com:389
Mon Jun 9 14:37:30 2008 failed with exit code 256.

several times but then continues...
then fails with:
ERROR 1050 (42S01) at line 1: Table 'scheduled_task' already exists

Mon Jun 9 14:43:17 2008: Error while running '/opt/zimbra/bin/mysql --user=zimbra --password=glmsEPS9lePwig9vjA9YujkxXsEn11m0 --database=zimbra --batch --skip-column-names'.

Script failed with code 256: - exiting

UPGRADE FAILED - exiting

Any help would be great!


p24t
Outstanding Member
Outstanding Member
Posts: 406
Joined: Fri Sep 12, 2014 10:28 pm

Trouble Migrating and Upgrading

Postby p24t » Mon Jun 09, 2008 3:09 pm

I don't know if you're following this or not, but here's a handy guide for migrating from one server to another: Zimbra :: Blog » Moving ZCS to Another Server
A couple things, firstly you will probably want to install the same version of Zimbra on the new server, and get it working before you upgrade to the new version. As for the LDAP listener error, you may want to check to see that there's nothing running on port 389 on that server already.
(I edited your post and removed your server URL)
j.mc
Posts: 13
Joined: Fri Sep 12, 2014 11:27 pm

Trouble Migrating and Upgrading

Postby j.mc » Mon Jun 09, 2008 3:12 pm

I apreciate the help I will give that a try and then repost.
j.mc
Posts: 13
Joined: Fri Sep 12, 2014 11:27 pm

Trouble Migrating and Upgrading

Postby j.mc » Tue Jun 10, 2008 1:11 pm

I have gotten much further in my quest to migrate the server from the old server to the new. I was able to move it to the new server but now while upgrading I am getting hung at:

Tue Jun 10 12:34:15 2008: Executing /opt/zimbra/libexec/scripts/migrate20070809-Signatures.pl
when I run top I see:

slapd is maxing out my processor and taking forever. is it hung? Should this take 12 hours to run? My Store is 30Gig

Return to “Migration”

Who is online

Users browsing this forum: Google [Bot] and 3 guests