ZCS 8.6 - zimbraMtaSmtpdMilters -> smtpd_milters - not working as in ZCS 8.0

General discussion about Zimbra Desktop.
Lukasz Michalik
Posts: 3
Joined: Wed Jan 28, 2015 3:53 pm
Location: Jelenia Gora
Contact:

ZCS 8.6 - zimbraMtaSmtpdMilters -> smtpd_milters - not working as in ZCS 8.0

Postby Lukasz Michalik » Wed Jan 28, 2015 4:25 pm

Hello,


I've upgraded from ZCS 8.0 to 8.6 and now have problems with zimbraMtaSmtpdMilters parameter. It's not "transferred" to MTA main.cf configuration file.


I'm installing milter using:


zmprov ms `hostname` zimbraMtaSmtpdMilters inet:localhost:7777


and later invoking


zmprov gs `hostname` zimbraMtaSmtpdMilters


gives me good results:


zimbraMtaSmtpdMilters: inet:localhost:7777


But main.cf configuration file has empty smtpd_milters property (it didn't update) and communication between MTA and milter is not working. When I manually change smtpd_milters everything is working like a charm, but only till next MTA restart.


In ZCS 8.0 this configuration worked without a problem. I'm missing something here? Any help would be appreciated.





Lukasz Michalik
Posts: 3
Joined: Wed Jan 28, 2015 3:53 pm
Location: Jelenia Gora
Contact:

ZCS 8.6 - zimbraMtaSmtpdMilters -> smtpd_milters - not working as in ZCS 8.0

Postby Lukasz Michalik » Mon Feb 02, 2015 12:55 pm

Anyone?
User avatar
Zied FAKHFAKH
Posts: 28
Joined: Tue Jan 07, 2014 1:43 am
Location: Tunisia
ZCS/ZD Version: ZCS 8.6
Contact:

ZCS 8.6 - zimbraMtaSmtpdMilters -> smtpd_milters - not working as in ZCS 8.0

Postby Zied FAKHFAKH » Mon Feb 16, 2015 4:36 am

Same problem here
fooz
Posts: 12
Joined: Sat Sep 13, 2014 12:57 am

ZCS 8.6 - zimbraMtaSmtpdMilters -> smtpd_milters - not working as in ZCS 8.0

Postby fooz » Mon Mar 30, 2015 6:01 pm

I've encountered the same problem on 8.6.0, quite annoying as my 3rd party anti-spam and several other milters are configured via this mechanism. This worked fine in 8.0.x, but not now.
fooz
Posts: 12
Joined: Sat Sep 13, 2014 12:57 am

ZCS 8.6 - zimbraMtaSmtpdMilters -> smtpd_milters - not working as in ZCS 8.0

Postby fooz » Mon Mar 30, 2015 6:14 pm

I looked all over at the various provisioning and couldn't figure out why it's not working...


Super-ghetto-but-functional hack is to add a line to the "command()" section of the /etc/init.d/zimbra startup script:


...


        su - zimbra -c "zmcontrol $1 </dev/null"
        su - zimbra -c "postconf -e 'smtpd_milters = inet:127.0.0.1:12322'"
}
...

Lukasz Michalik
Posts: 3
Joined: Wed Jan 28, 2015 3:53 pm
Location: Jelenia Gora
Contact:

ZCS 8.6 - zimbraMtaSmtpdMilters -> smtpd_milters - not working as in ZCS 8.0

Postby Lukasz Michalik » Tue Apr 07, 2015 2:53 pm

Bugzilla issue: https://bugzilla.zimbra.com/show_bug.cgi?id=97706



For now I've found two workarounds.


1. Remove these lines from conf/zmconfigd.cf configuration file, smtpd_milters will not be overwritten.


POSTCONF smtpd_milters


if VAR zimbraMtaSmtpdMilters


    POSTCONF smtpd_milters VAR zimbraMtaSmtpdMilters


fi


2. Set zimbraMtaServerEnabled to TRUE, this will enable build-in milter but will preserve custom milters entries.


Return to “General Questions”

Who is online

Users browsing this forum: No registered users and 2 guests