Failed to upgrade from 8.6 to 8.7 Zimbra

Ask questions about your setup or get help installing ZCS server (ZD section below).
duronus
Posts: 1
Joined: Wed Jun 08, 2016 6:55 am

Re: Failed to upgrade from 8.6 to 8.7 Zimbra

Postby duronus » Tue Aug 16, 2016 12:24 pm

my zimbra 8.6 1200 FOSS did not upgrades

The error is the same

dpkg: error processing archive /var/cache/apt/archives/zimbra-perl-mail-spamassassin_3.4.1-1zimbra8.7b1.14.04_all.deb (--unpack):
dpkg: error processing archive /var/cache/apt/archives/zimbra-spamassassin-rules_1.0.0-1zimbra8.7b1.14.04_all.deb (--unpack):

-------------------------

/var/cache/apt/archives/zimbra-osl_1.0.9-1zimbra8.7b1.14.04_all.deb
/var/cache/apt/archives/zimbra-perl-mail-spamassassin_3.4.1-1zimbra8.7b1.14.04_all.deb
/var/cache/apt/archives/zimbra-spamassassin-rules_1.0.0-1zimbra8.7b1.14.04_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

has anyone solved this problem


sbourdette
Posts: 5
Joined: Sat Sep 13, 2014 1:56 am

Re: Failed to upgrade from 8.6 to 8.7 Zimbra

Postby sbourdette » Wed Aug 17, 2016 8:31 am

Any News or Idea ?
patobasalo
Posts: 6
Joined: Mon Aug 01, 2016 12:42 am

Re: Failed to upgrade from 8.6 to 8.7 Zimbra

Postby patobasalo » Tue Aug 23, 2016 3:11 pm

sbourdette wrote:Any News or Idea ?
Saukatz
Posts: 1
Joined: Wed Sep 14, 2016 6:28 am

Re: Failed to upgrade from 8.6 to 8.7 Zimbra

Postby Saukatz » Wed Sep 14, 2016 7:43 am

Hallo Leute,
mein Englisch ist nicht so gut und deshalb schreibe ich in Deutsch.
Das wichtigste sind ja die Befehle. :D

Ich hab das gleich Problem und habe für mich eine Lösung gefunden. Warum das so funktioniert, müssen die Programmierer von Zimbra heraus finden.

Hier geht es los:

Zuerst Zimbra ganz normal das Update starten bis das Update abbricht

root@mail:~/install/zcs-8.7.0_GAxxxx# ./install.sh

Operations logged to /tmp/install.log.xxxxxx
Checking for existing installation...
......
ERROR: Unable to install required packages
WARNING: REMOTE PACKAGE INSTALLATION FAILED.
To proceed, review the instructions at:
https://wiki.zimbra.com/wiki/Recovering ... de_failure
Failure to follow the instructions on the wiki will result in complete data loss.
......

Wir schauen uns das Install Log an
cat /tmp/install.log.xxxxxx.

Das sollte dann etwa so aussehen.

Errors were encountered while processing:
/var/cache/apt/archives/zimbra-osl_1.0.9-1zimbra8.7b1.14.04_all.deb
/var/cache/apt/archives/zimbra-perl-mail-spamassassin_3.4.1-1zimbra8.7b1.14.04_all.deb
/var/cache/apt/archives/zimbra-spamassassin-rules_1.0.0-1zimbra8.7b1.14.04_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Dann diese Befehle ausführen:

apt-get clean
apt-get update
cd /var/cache/apt/archives
wget https://repo.zimbra.com/apt/87/pool/zim ... 04_all.deb
apt-get download zimbra-perl-mail-spamassassin*
apt-get download zimbra-spamassassin-rules*
dpkg --configure -a
dpkg -i --force-overwrite zimbra-*

#### Alert / Wichtig / hier müsst Ihr den LDAP von der 8.6 wieder installieren ####

dpkg -i /verzeichnis/zimbra_8.6.0/zcs-8.6.0_GA_1153.UBUNTU14_64.20141215151116/packages/zimbra-ldap_8.6.0.GA.1153.UBUNTU14.64_amd64.deb
su zimbra
ldap start
exit
cd /in das verzeichnis der installation/zcs-8.7.0_xxxxxx/
./install.sh --force-upgrade --skip-activation-check --skip-upgrade-check

So sieht es dann bei mir aus:

root@mail:~/install/zcs-8.7.0_GA_1659.UBUNTU14_64.20160628202701# ./install.sh --force-upgrade --skip-activation-check --skip-upgrade-check

Operations logged to /tmp/install.log.upBC0tra
Checking for existing installation...
zimbra-ldap...FOUND zimbra-ldap-8.6.0.GA.1153.UBUNTU14.64
zimbra-logger...NOT FOUND
zimbra-mta...FOUND zimbra-mta-8.6.0.GA.1153.UBUNTU14.64
zimbra-dnscache...NOT FOUND
zimbra-snmp...NOT FOUND
zimbra-store...NOT FOUND
zimbra-apache...NOT FOUND
zimbra-spell...NOT FOUND
zimbra-convertd...NOT FOUND
zimbra-memcached...FOUND zimbra-memcached-1.4.25-1zimbra8.7b1.14.04
zimbra-proxy...NOT FOUND
zimbra-archiving...NOT FOUND
zimbra-core...FOUND zimbra-core-8.6.0.GA.1153.UBUNTU14.64
ZCS upgrade from 8.6.0 to 8.7.0 will be performed.
Checking for existing proxy service in your environment
Checking for existing memcached service in your environment


----------------------------------------------------------------------
PLEASE READ THIS AGREEMENT CAREFULLY BEFORE USING THE SOFTWARE.
SYNACOR, INC. ("SYNACOR") WILL ONLY LICENSE THIS SOFTWARE TO YOU IF YOU
FIRST ACCEPT THE TERMS OF THIS AGREEMENT. BY DOWNLOADING OR INSTALLING
THE SOFTWARE, OR USING THE PRODUCT, YOU ARE CONSENTING TO BE BOUND BY
THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS
AGREEMENT, THEN DO NOT DOWNLOAD, INSTALL OR USE THE PRODUCT.

License Terms for this Zimbra Collaboration Suite Software:
https://www.zimbra.com/license/zimbra-p ... a-2-6.html
----------------------------------------------------------------------



Do you agree with the terms of the software license agreement? [N] y



Checking current number of databases...

Checking for installable packages

Found zimbra-core
Found zimbra-ldap
Found zimbra-logger
Found zimbra-mta
Found zimbra-dnscache
Found zimbra-snmp
Found zimbra-store
Found zimbra-apache
Found zimbra-spell
Found zimbra-memcached
Found zimbra-proxy



Use Zimbra's package repository [Y]
Configuring package repository

The Zimbra Collaboration Server appears to already be installed.
It can be upgraded with no effect on existing accounts,
or the current installation can be completely removed prior
to installation for a clean install.

Do you wish to upgrade? [Y] y

Scanning for any new or additional packages available for installation
Existing packages will be upgraded
Upgrading zimbra-core
Upgrading zimbra-ldap

Install zimbra-logger [N] y
Upgrading zimbra-mta

Install zimbra-dnscache [N]

Install zimbra-snmp [N] y

Install zimbra-store [N] y

Install zimbra-apache [N] y

Install zimbra-spell [N] y
Upgrading zimbra-memcached

Install zimbra-proxy [N] y
Checking required space for zimbra-core
Checking space for zimbra-store
Checking required packages for zimbra-store
zimbra-store package check complete.

Installing:
zimbra-core
zimbra-ldap
zimbra-logger
zimbra-mta
zimbra-snmp
zimbra-store
zimbra-apache
zimbra-spell
zimbra-memcached
zimbra-proxy

The system will be modified. Continue? [N] y

Shutting down zimbra mail

Backing up the ldap database...done.

Removing existing packages

zimbra-ldap...done
zimbra-mta...done
zimbra-memcached...done
zimbra-core...done

Removing deployed webapp directories
Installing packages

Local packages zimbra-core zimbra-ldap zimbra-logger zimbra-mta zimbra-snmp zimbra-store zimbra-apache zimbra-spell zimbra-proxy selected for installation
Monitor /tmp/install.log.upBC0tra for package installation progress
Remote package installation started
Installing zimbra-core-components zimbra-ldap-components zimbra-mta-components zimbra-snmp-components zimbra-store-components zimbra-apache-components zimbra-spell-components zimbra-memcached zimbra-proxy-components....done
Local package installation started
Installing zimbra-core zimbra-ldap zimbra-logger zimbra-mta zimbra-snmp zimbra-store zimbra-apache zimbra-spell zimbra-proxy...done
............
...
............
You have the option of notifying Zimbra of your installation.
This helps us to track the uptake of the Zimbra Collaboration Server.
The only information that will be transmitted is:
The VERSION of zcs installed (8.7.0_GA_1659_UBUNTU14_64)
The ADMIN EMAIL ADDRESS created (admin@xxxxxxxx.de)

Notify Zimbra of your installation? [Yes]
............
...
............

Setting up zimbra crontab...done.

Moving /tmp/zmsetup.20160914-082703.log to /opt/zimbra/log

Configuration complete - press return to exit

ENDE


Bitte nicht die schritte nach der Installation vergessen...
https://wiki.zimbra.com/wiki/Zimbra_Rel ... .0/Upgrade
Singel Server Upgrade ab Punkt 11 und 12

Diese Anleitung ist ohne Gewehr...
Über ein Positives Feedback würde ich mich freuen. :)

MFG Saukatz
halfgaar
Advanced member
Advanced member
Posts: 84
Joined: Sat Sep 13, 2014 12:54 am
Location: Netherlands
ZCS/ZD Version: Release 8.8.12.GA.3794.UBUNTU16.64

Re: Failed to upgrade from 8.6 to 8.7 Zimbra

Postby halfgaar » Wed Oct 05, 2016 7:12 pm

I was quite eager to try 8.7, but I just had the same issue trying to upgrade from 8.6 to 8.7, community edition. I easily fixed the failed upgrade by reverting the LVM snapshot of the virtual machine.

What upgrade paths to 8.7 have been tested? It seems to me that with 8.7, instead of upgrading the existing packages like zimbra-core and zimbra-mta, certain components are now installed from other debs. Does that mean the old zimbra-core and zimbra-mta aren't upgraded, but become orphaned, creating the conflict? Yaroze said on August 14th that they removed all previous Zimbra packages and installed 8.7 basically as-if new.

I couldn't find an existing bug report, so I made one.
D.o.n.g.h.w.a.n
Posts: 3
Joined: Sat Sep 13, 2014 2:54 am

Re: Failed to upgrade from 8.6 to 8.7 Zimbra

Postby D.o.n.g.h.w.a.n » Tue Oct 18, 2016 3:10 pm

Vielen Dank ! It works ;)

Saukatz wrote:Hallo Leute,
mein Englisch ist nicht so gut und deshalb schreibe ich in Deutsch.
Das wichtigste sind ja die Befehle. :D

Ich hab das gleich Problem und habe für mich eine Lösung gefunden. Warum das so funktioniert, müssen die Programmierer von Zimbra heraus finden.

Hier geht es los:

Zuerst Zimbra ganz normal das Update starten bis das Update abbricht

root@mail:~/install/zcs-8.7.0_GAxxxx# ./install.sh

Operations logged to /tmp/install.log.xxxxxx
Checking for existing installation...
......
ERROR: Unable to install required packages
WARNING: REMOTE PACKAGE INSTALLATION FAILED.
To proceed, review the instructions at:
https://wiki.zimbra.com/wiki/Recovering ... de_failure
Failure to follow the instructions on the wiki will result in complete data loss.
......

Wir schauen uns das Install Log an
cat /tmp/install.log.xxxxxx.

Das sollte dann etwa so aussehen.

Errors were encountered while processing:
/var/cache/apt/archives/zimbra-osl_1.0.9-1zimbra8.7b1.14.04_all.deb
/var/cache/apt/archives/zimbra-perl-mail-spamassassin_3.4.1-1zimbra8.7b1.14.04_all.deb
/var/cache/apt/archives/zimbra-spamassassin-rules_1.0.0-1zimbra8.7b1.14.04_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Dann diese Befehle ausführen:

apt-get clean
apt-get update
cd /var/cache/apt/archives
wget https://repo.zimbra.com/apt/87/pool/zim ... 04_all.deb
apt-get download zimbra-perl-mail-spamassassin*
apt-get download zimbra-spamassassin-rules*
dpkg --configure -a
dpkg -i --force-overwrite zimbra-*

#### Alert / Wichtig / hier müsst Ihr den LDAP von der 8.6 wieder installieren ####

dpkg -i /verzeichnis/zimbra_8.6.0/zcs-8.6.0_GA_1153.UBUNTU14_64.20141215151116/packages/zimbra-ldap_8.6.0.GA.1153.UBUNTU14.64_amd64.deb
su zimbra
ldap start
exit
cd /in das verzeichnis der installation/zcs-8.7.0_xxxxxx/
./install.sh --force-upgrade --skip-activation-check --skip-upgrade-check

So sieht es dann bei mir aus:

root@mail:~/install/zcs-8.7.0_GA_1659.UBUNTU14_64.20160628202701# ./install.sh --force-upgrade --skip-activation-check --skip-upgrade-check

Operations logged to /tmp/install.log.upBC0tra
Checking for existing installation...
zimbra-ldap...FOUND zimbra-ldap-8.6.0.GA.1153.UBUNTU14.64
zimbra-logger...NOT FOUND
zimbra-mta...FOUND zimbra-mta-8.6.0.GA.1153.UBUNTU14.64
zimbra-dnscache...NOT FOUND
zimbra-snmp...NOT FOUND
zimbra-store...NOT FOUND
zimbra-apache...NOT FOUND
zimbra-spell...NOT FOUND
zimbra-convertd...NOT FOUND
zimbra-memcached...FOUND zimbra-memcached-1.4.25-1zimbra8.7b1.14.04
zimbra-proxy...NOT FOUND
zimbra-archiving...NOT FOUND
zimbra-core...FOUND zimbra-core-8.6.0.GA.1153.UBUNTU14.64
ZCS upgrade from 8.6.0 to 8.7.0 will be performed.
Checking for existing proxy service in your environment
Checking for existing memcached service in your environment


----------------------------------------------------------------------
PLEASE READ THIS AGREEMENT CAREFULLY BEFORE USING THE SOFTWARE.
SYNACOR, INC. ("SYNACOR") WILL ONLY LICENSE THIS SOFTWARE TO YOU IF YOU
FIRST ACCEPT THE TERMS OF THIS AGREEMENT. BY DOWNLOADING OR INSTALLING
THE SOFTWARE, OR USING THE PRODUCT, YOU ARE CONSENTING TO BE BOUND BY
THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS
AGREEMENT, THEN DO NOT DOWNLOAD, INSTALL OR USE THE PRODUCT.

License Terms for this Zimbra Collaboration Suite Software:
https://www.zimbra.com/license/zimbra-p ... a-2-6.html
----------------------------------------------------------------------



Do you agree with the terms of the software license agreement? [N] y



Checking current number of databases...

Checking for installable packages

Found zimbra-core
Found zimbra-ldap
Found zimbra-logger
Found zimbra-mta
Found zimbra-dnscache
Found zimbra-snmp
Found zimbra-store
Found zimbra-apache
Found zimbra-spell
Found zimbra-memcached
Found zimbra-proxy



Use Zimbra's package repository [Y]
Configuring package repository

The Zimbra Collaboration Server appears to already be installed.
It can be upgraded with no effect on existing accounts,
or the current installation can be completely removed prior
to installation for a clean install.

Do you wish to upgrade? [Y] y

Scanning for any new or additional packages available for installation
Existing packages will be upgraded
Upgrading zimbra-core
Upgrading zimbra-ldap

Install zimbra-logger [N] y
Upgrading zimbra-mta

Install zimbra-dnscache [N]

Install zimbra-snmp [N] y

Install zimbra-store [N] y

Install zimbra-apache [N] y

Install zimbra-spell [N] y
Upgrading zimbra-memcached

Install zimbra-proxy [N] y
Checking required space for zimbra-core
Checking space for zimbra-store
Checking required packages for zimbra-store
zimbra-store package check complete.

Installing:
zimbra-core
zimbra-ldap
zimbra-logger
zimbra-mta
zimbra-snmp
zimbra-store
zimbra-apache
zimbra-spell
zimbra-memcached
zimbra-proxy

The system will be modified. Continue? [N] y

Shutting down zimbra mail

Backing up the ldap database...done.

Removing existing packages

zimbra-ldap...done
zimbra-mta...done
zimbra-memcached...done
zimbra-core...done

Removing deployed webapp directories
Installing packages

Local packages zimbra-core zimbra-ldap zimbra-logger zimbra-mta zimbra-snmp zimbra-store zimbra-apache zimbra-spell zimbra-proxy selected for installation
Monitor /tmp/install.log.upBC0tra for package installation progress
Remote package installation started
Installing zimbra-core-components zimbra-ldap-components zimbra-mta-components zimbra-snmp-components zimbra-store-components zimbra-apache-components zimbra-spell-components zimbra-memcached zimbra-proxy-components....done
Local package installation started
Installing zimbra-core zimbra-ldap zimbra-logger zimbra-mta zimbra-snmp zimbra-store zimbra-apache zimbra-spell zimbra-proxy...done
............
...
............
You have the option of notifying Zimbra of your installation.
This helps us to track the uptake of the Zimbra Collaboration Server.
The only information that will be transmitted is:
The VERSION of zcs installed (8.7.0_GA_1659_UBUNTU14_64)
The ADMIN EMAIL ADDRESS created (admin@xxxxxxxx.de)

Notify Zimbra of your installation? [Yes]
............
...
............

Setting up zimbra crontab...done.

Moving /tmp/zmsetup.20160914-082703.log to /opt/zimbra/log

Configuration complete - press return to exit

ENDE


Bitte nicht die schritte nach der Installation vergessen...
https://wiki.zimbra.com/wiki/Zimbra_Rel ... .0/Upgrade
Singel Server Upgrade ab Punkt 11 und 12

Diese Anleitung ist ohne Gewehr...
Über ein Positives Feedback würde ich mich freuen. :)

MFG Saukatz
halfgaar
Advanced member
Advanced member
Posts: 84
Joined: Sat Sep 13, 2014 12:54 am
Location: Netherlands
ZCS/ZD Version: Release 8.8.12.GA.3794.UBUNTU16.64

Re: Failed to upgrade from 8.6 to 8.7 Zimbra

Postby halfgaar » Sun Oct 30, 2016 8:48 am

The release notes of Zimbra 8.7.1, just released, state:

Zimbra Collaboration 8.7.0 had some important issues upgrading from older releases of Zimbra Collaboration. We have been working diligently with Customers and Partners who reported the issues, and today we announce the fix of these critical issues while upgrading.

It’s now perfectly safe to upgrade from previous releases of ZCS, but remember to use the new Zimbra Collaboration 8.7.1.


This was not based on this bug report, so it's a bit unclear if it's the same issue?

Did anybody try it yet?
User avatar
tonster
Zimbra Employee
Zimbra Employee
Posts: 312
Joined: Fri Feb 21, 2014 10:14 am
Location: Ypsilanti, MI
ZCS/ZD Version: Release 8.7.0_GA_1659.RHEL6_64_2016

Re: Failed to upgrade from 8.6 to 8.7 Zimbra

Postby tonster » Sun Oct 30, 2016 4:23 pm

halfgaar wrote:The release notes of Zimbra 8.7.1, just released, state:

Zimbra Collaboration 8.7.0 had some important issues upgrading from older releases of Zimbra Collaboration. We have been working diligently with Customers and Partners who reported the issues, and today we announce the fix of these critical issues while upgrading.

It’s now perfectly safe to upgrade from previous releases of ZCS, but remember to use the new Zimbra Collaboration 8.7.1.


This was not based on this bug report, so it's a bit unclear if it's the same issue?

Did anybody try it yet?


The issue was related to license activation, and so only affected some NE customers, but did not affect anyone running FOSS.
zot
Posts: 19
Joined: Sat Sep 13, 2014 2:56 am

Re: Failed to upgrade from 8.6 to 8.7 Zimbra

Postby zot » Mon Oct 31, 2016 9:34 am

Just wanted to say that the exact same problems showed up at my 8.6.0 -> 8.7.1 (FOSS version) update I did today. Thanks a ton to Saukatz, those instructions worked and saved me a ton of problems.

Is the FOSS upgrade path not tested anymore?
User avatar
DualBoot
Elite member
Elite member
Posts: 1165
Joined: Mon Apr 18, 2016 8:18 pm
Location: France - Earth
ZCS/ZD Version: ZCS FLOSS - 8.8.15 Mutli servers
Contact:

Re: Failed to upgrade from 8.6 to 8.7 Zimbra

Postby DualBoot » Mon Oct 31, 2016 4:14 pm

Hello,

I have this warning since I have update from 8.6 to 8.7 , I have just update from 8.7.0 to 8.7.1 :

Code: Select all

Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/\${ <-- HERE zimbra_home}/ at /opt/zimbra/libexec/zmupgrade.pm line 1518, <DATA> line 755.
Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/\${ <-- HERE zimbra_home}/ at /opt/zimbra/libexec/zmupgrade.pm line 1561, <DATA> line 755.
Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/\${ <-- HERE zimbra_home}/ at /opt/zimbra/libexec/zmupgrade.pm line 1690, <DATA> line 755.
Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/\${ <-- HERE zimbra_home}/ at /opt/zimbra/libexec/zmupgrade.pm line 1731, <DATA> line 755.
Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/\${ <-- HERE zimbra_home}/ at /opt/zimbra/libexec/zmupgrade.pm line 1740, <DATA> line 755.
Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/\${ <-- HERE zimbra_home}/ at /opt/zimbra/libexec/zmupgrade.pm line 1749, <DATA> line 755.
Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/\${ <-- HERE zimbra_home}/ at /opt/zimbra/libexec/zmupgrade.pm line 1758, <DATA> line 755.
Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/\${ <-- HERE zimbra_home}/ at /opt/zimbra/libexec/zmupgrade.pm line 1767, <DATA> line 755.


Is there any entry in the bugzilla about it ? I did not find it.

regards,

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 7 guests