Ayuda URGENTE con Permisos de Usuario Zimbra

alexsierrac
Posts: 25
Joined: Sat Sep 30, 2017 7:51 pm
Location: Bogotá - Colombia

Ayuda URGENTE con Permisos de Usuario Zimbra

Postby alexsierrac » Tue Apr 17, 2018 9:53 pm

Buen dia Expertos:

Recurro a su gran experiencia para que me ayuden a solucionar un gran inconveniente que me ha sucedido con mi servidor Zimbra

Mi servidor corre en Ubuntu Server 16.04 y la version de Zimbra es 8.7.11

Realice unas actualizaciones del sistema operativo y al reiniciar el servidor algunos servicios del ZIMBRA no se inician, entre ellos el MTA. Cuando intento reiniciar los servicios de Zimbra por linea de comandos para estos servicios me arroja el mensaje [sudo] password for zimbra

Esto antes de la actualizacion no estaba sucediendo y el servidor funcionaba a la perfecccion. Ahora no permite el envio ni recibo de mensajes

Por favor ayudenme cuanto antes, pues no soy muy experto en Linux ni Zimbra

Les agradezco mucho su pronta respuesta. saludos...


alexsierrac
Posts: 25
Joined: Sat Sep 30, 2017 7:51 pm
Location: Bogotá - Colombia

[RESUELTO] Ayuda URGENTE con Permisos de Usuario Zimbra

Postby alexsierrac » Wed Apr 18, 2018 1:23 pm

Buen dia:

Afortunadamente logre resolverlo. Resulta que en el directorio /etc/sudoers.d se habia borrado un archivo llamado 02_zimbra-mta el cual contiene las siguientes lineas:

%zimbra ALL=NOPASSWD:/opt/zimbra/common/sbin/postfix
%zimbra ALL=NOPASSWD:/opt/zimbra/common/sbin/postalias
%zimbra ALL=NOPASSWD:/opt/zimbra/common/sbin/qshape.pl
%zimbra ALL=NOPASSWD:/opt/zimbra/common/sbin/postconf
%zimbra ALL=NOPASSWD:/opt/zimbra/common/sbin/postsuper
%zimbra ALL=NOPASSWD:/opt/zimbra/common/sbin/postcat
%zimbra ALL=NOPASSWD:/opt/zimbra/libexec/zmqstat
%zimbra ALL=NOPASSWD:/opt/zimbra/libexec/zmmtastatus
%zimbra ALL=NOPASSWD:/opt/zimbra/common/sbin/amavis-mc

Al restablecer este archivo, se soluciono de inmediato el problema

Cabe resaltar que ya habia aplicado soluciones como la indicada aqui: https://wiki.zimbra.com/wiki/Zimbra_ser ... oers_issue, la cual sugiere editar el archivo /etc/sudoers y agregar:

%zimbra ALL=NOPASSWD:/opt/zimbra/libexec/zmstat-fd *
%zimbra ALL=NOPASSWD:/opt/zimbra/libexec/zmslapd
%zimbra ALL=NOPASSWD:/opt/zimbra/postfix/sbin/postfix, /opt/zimbra/postfix/sbin/postalias, /opt/zimbra/postfix/sbin/qshape.pl, /opt/zimbra/postfix/sbin/postconf,/opt/zimbra/postfix/sbin/postsuper
%zimbra ALL=NOPASSWD:/opt/zimbra/libexec/zmqstat,/opt/zimbra/libexec/zmmtastatus
%zimbra ALL=NOPASSWD:/opt/zimbra/amavisd/sbin/amavis-mc
%zimbra ALL=NOPASSWD:/opt/zimbra/libexec/zmunbound
%zimbra ALL=NOPASSWD:/sbin/resolvconf *
%zimbra ALL=NOPASSWD:/opt/zimbra/libexec/zmmailboxdmgr
%zimbra ALL=NOPASSWD:/opt/zimbra/bin/zmcertmgr
%zimbra ALL=NOPASSWD:/opt/zimbra/nginx/sbin/nginx

Pero esto NO funciono

Tambien aplique otra solucion encontrada aqui: https://wiki.zimbra.com/wiki/Sudoers, la cual sugiere editar el archivo /etc/sudoers.d/01_zimbra y agregar:

%zimbra ALL=NOPASSWD:/opt/zimbra/common/sbin/amavis-mc
%zimbra ALL=NOPASSWD:/opt/zimbra/common/sbin/nginx
%zimbra ALL=NOPASSWD:/opt/zimbra/common/sbin/postalias
%zimbra ALL=NOPASSWD:/opt/zimbra/common/sbin/postcat
%zimbra ALL=NOPASSWD:/opt/zimbra/common/sbin/postconf
%zimbra ALL=NOPASSWD:/opt/zimbra/common/sbin/postfix
%zimbra ALL=NOPASSWD:/opt/zimbra/common/sbin/postsuper
%zimbra ALL=NOPASSWD:/opt/zimbra/common/sbin/qshape.pl
%zimbra ALL=NOPASSWD:/opt/zimbra/libexec/zmdnscachealign *
%zimbra ALL=NOPASSWD:/opt/zimbra/libexec/zmmailboxdmgr
%zimbra ALL=NOPASSWD:/opt/zimbra/libexec/zmmtastatus
%zimbra ALL=NOPASSWD:/opt/zimbra/libexec/zmqstat
%zimbra ALL=NOPASSWD:/opt/zimbra/libexec/zmslapd
%zimbra ALL=NOPASSWD:/opt/zimbra/libexec/zmstat-fd *
%zimbra ALL=NOPASSWD:/opt/zimbra/libexec/zmunbound

Pero esto tampoco soluciono el problema

Espero les sirva de mucha ayuda. Saludos...

Return to “Spanish”

Who is online

Users browsing this forum: No registered users and 0 guests