upgrade from 8.8.6 to 8.8.8 using the tar ball and saying NO to use ZIMBRA Internet repos fails

Ask questions about your setup or get help installing ZCS server (ZD section below).
ivanbishop
Posts: 5
Joined: Thu Mar 12, 2015 4:27 pm

upgrade from 8.8.6 to 8.8.8 using the tar ball and saying NO to use ZIMBRA Internet repos fails

Postby ivanbishop » Tue Jul 03, 2018 2:12 am

upgrade fails.

Centos 6.9

zmcontrol -v
Release 8.8.6_GA_1906.RHEL6_64_20171130041047 RHEL6_64 FOSS edition.


NO CLUES in the install log and the RPM files it says i cannot find ARE on disk having been extracted from the TGZ file.

ANY IDEAS?





Thanks


[root@mail zcs-8.8.8_GA_2009.RHEL6_64.20180322150747]# ./install.sh --platform-override

Operations logged to /tmp/install.log.hwBX1M8g
Checking for existing installation...
zimbra-chat...NOT FOUND
zimbra-drive...NOT FOUND
zimbra-imapd...NOT FOUND
zimbra-license-tools...NOT FOUND
zimbra-license-extension...NOT FOUND
zimbra-network-store...NOT FOUND
zimbra-network-modules-ng...NOT FOUND
zimbra-ldap...FOUND zimbra-ldap-8.8.6_GA_1906
zimbra-logger...FOUND zimbra-logger-8.8.6_GA_1906
zimbra-mta...FOUND zimbra-mta-8.8.6_GA_1906
zimbra-dnscache...FOUND zimbra-dnscache-8.8.6_GA_1906
zimbra-snmp...FOUND zimbra-snmp-8.8.6_GA_1906
zimbra-store...FOUND zimbra-store-8.8.6_GA_1906
zimbra-apache...FOUND zimbra-apache-8.8.6_GA_1906
zimbra-spell...FOUND zimbra-spell-8.8.6_GA_1906
zimbra-convertd...NOT FOUND
zimbra-memcached...FOUND zimbra-memcached-1.4.37-2
zimbra-proxy...FOUND zimbra-proxy-8.8.6_GA_1906
zimbra-archiving...NOT FOUND
zimbra-core...FOUND zimbra-core-8.8.6_GA_1906
ZCS upgrade from 8.8.6 to 8.8.8 will be performed.
Validating ldap configuration
LDAP validation succeeded. Continuing.


----------------------------------------------------------------------
PLEASE READ THIS AGREEMENT CAREFULLY BEFORE USING THE SOFTWARE.
SYNACOR, INC. ("SYNACOR") WILL ONLY LICENSE THIS SOFTWARE TO YOU IF YOU
FIRST ACCEPT THE TERMS OF THIS AGREEMENT. BY DOWNLOADING OR INSTALLING
THE SOFTWARE, OR USING THE PRODUCT, YOU ARE CONSENTING TO BE BOUND BY
THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS
AGREEMENT, THEN DO NOT DOWNLOAD, INSTALL OR USE THE PRODUCT.

License Terms for this Zimbra Collaboration Suite Software:
https://www.zimbra.com/license/zimbra-p ... a-2-6.html
----------------------------------------------------------------------



Do you agree with the terms of the software license agreement? [N] y



Checking current number of databases...

Do you want to verify message store database integrity? [Y] n


Use Zimbra's package repository [Y] n

Checking for installable packages

Found zimbra-core (local)
Found zimbra-ldap (local)
Found zimbra-logger (local)
Found zimbra-mta (local)
Found zimbra-dnscache (local)
Found zimbra-snmp (local)
Found zimbra-store (local)
Found zimbra-apache (local)
Found zimbra-spell (local)
Found zimbra-proxy (local)
Found zimbra-imapd (local)


The Zimbra Collaboration Server appears to already be installed.
It can be upgraded with no effect on existing accounts,
or the current installation can be completely removed prior
to installation for a clean install.

Do you wish to upgrade? [Y] y

Scanning for any new or additional packages available for installation
Existing packages will be upgraded
Upgrading zimbra-core
Upgrading zimbra-ldap
Upgrading zimbra-logger
Upgrading zimbra-mta
Upgrading zimbra-dnscache
Upgrading zimbra-snmp
Upgrading zimbra-store
Upgrading zimbra-apache
Upgrading zimbra-spell
Upgrading zimbra-proxy

Install zimbra-imapd (BETA - for evaluation only) [N] n
Checking required space for zimbra-core
Checking space for zimbra-store
Checking required packages for zimbra-store
zimbra-store package check complete.

Installing:
zimbra-core
zimbra-ldap
zimbra-logger
zimbra-mta
zimbra-dnscache
zimbra-snmp
zimbra-store
zimbra-apache
zimbra-spell
zimbra-proxy

The system will be modified. Continue? [N] y

Beginning Installation - see /tmp/install.log.hwBX1M8g for details...

zimbra-core-components is missing. ERROR
zimbra-timezone-data will be installed.
zimbra-common-mbox-db will be installed.
zimbra-common-mbox-docs will be installed.
zimbra-common-core-jar will be installed.
zimbra-common-mbox-native-lib will be installed.
zimbra-common-mbox-conf-attrs will be installed.
zimbra-common-core-libs will be installed.
zimbra-common-mbox-conf will be installed.
zimbra-common-mbox-conf-rights will be installed.
zimbra-common-mbox-conf-msgs will be installed.
zimbra-core will be installed.
zimbra-ldap-components is missing. ERROR
zimbra-ldap will be installed.
zimbra-logger will be installed.
zimbra-mta-components is missing. ERROR
zimbra-mta will be installed.
zimbra-dnscache-components is missing. ERROR
zimbra-dnscache will be installed.
zimbra-snmp-components is missing. ERROR
zimbra-snmp will be installed.
zimbra-store-components is missing. ERROR
zimbra-jetty-distribution is missing. ERROR
zimbra-mbox-war will be installed.
zimbra-mbox-conf will be installed.
zimbra-mbox-service will be installed.
zimbra-mbox-store-libs will be installed.
zimbra-mbox-webclient-war will be installed.
zimbra-mbox-admin-console-war will be installed.
zimbra-mbox-admin-common will be installed.
zimbra-store will be installed.
zimbra-apache-components is missing. ERROR
zimbra-apache will be installed.
zimbra-spell-components is missing. ERROR
zimbra-spell will be installed.
zimbra-proxy-components is missing. ERROR
zimbra-memcached is missing. ERROR
zimbra-proxy will be installed.

Unable to find missing packages in repository. System is not modified.


ivanbishop
Posts: 5
Joined: Thu Mar 12, 2015 4:27 pm

Re: upgrade from 8.8.6 to 8.8.8 using the tar ball and saying NO to use ZIMBRA Internet repos fails

Postby ivanbishop » Tue Jul 03, 2018 2:52 am

additional info

ALL my repos are reachable EXCEPT zimbra

e.g.
yum clean all && yum clean metadata && yum clean dbcache && yum makecache && yum update^C
[root@mail yum.repos.d]# yum update
Loaded plugins: fastestmirror, refresh-packagekit, security
Setting up Update Process
Loading mirror speeds from cached hostfile
>> LOTS OF GOOD OUTPUT<<< THEN....
* base: mirrors.sonic.net
* epel: mirror.sfo12.us.leaseweb.net
* extras: centos-distro.1gservers.com
* updates: mirror.sfo12.us.leaseweb.net
https://repo.zimbra.com/rpm/87/rhel6/re ... repomd.xml: [Errno 12] Timeout on https://repo.zimbra.com/rpm/87/rhel6/re ... repomd.xml: (28, 'connect() timed out!')
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: zimbra. Please verify its path and try again


repo file looks like (generated by util script)

cat /tmp/zimbra.repo
[zimbra]
name=Zimbra RPM Repository
baseurl=https://repo.zimbra.com/rpm/87/rhel6
gpgcheck=1
enabled=1
[zimbra-v1]
name=Zimbra New RPM Repository
baseurl=https://repo.zimbra.com/rpm/zv1/rhel6
gpgcheck=1
enabled=1
[zimbra-888-patch]
name=Zimbra New RPM Repository
baseurl=https://repo.zimbra.com/rpm/888patch/rhel6
gpgcheck=1
enabled=1
User avatar
tonster
Zimbra Employee
Zimbra Employee
Posts: 297
Joined: Fri Feb 21, 2014 10:14 am
Location: Ypsilanti, MI
ZCS/ZD Version: Release 8.7.0_GA_1659.RHEL6_64_2016

Re: upgrade from 8.8.6 to 8.8.8 using the tar ball and saying NO to use ZIMBRA Internet repos fails

Postby tonster » Wed Jul 04, 2018 4:55 am

ivanbishop wrote:upgrade fails.

Centos 6.9

zmcontrol -v
Release 8.8.6_GA_1906.RHEL6_64_20171130041047 RHEL6_64 FOSS edition.


NO CLUES in the install log and the RPM files it says i cannot find ARE on disk having been extracted from the TGZ file.

ANY IDEAS?





Thanks




I think part of your issue here is not understanding what FOUND and NOT FOUND mean. This indicates that the package was found to be installed, not that it was found to exist on the local filesystem.

Why are you saying not to use the zimbra repo after executing ./install.sh? You also no longer need to use --platform-override on centos. Centos has been supported for some time now.
ivanbishop
Posts: 5
Joined: Thu Mar 12, 2015 4:27 pm

Re: upgrade from 8.8.6 to 8.8.8 using the tar ball and saying NO to use ZIMBRA Internet repos fails

Postby ivanbishop » Thu Jul 12, 2018 8:01 pm

Thanks Tonster.

To be clear I'd rather NOT be downloading tarballs and running a local install.

I want to setup and use the zimbra repo directly.

So, may I ask you to
[1] post the CORRECT zimbra.repo file?
[2] show a yum repolist

The docs are incorrect as they reference a toplevel domain (.tld) rather than the zimbra repo.

Once I have that file I should be able to yum repolist and "what provides" and see ALL the .RPMs you ship from the repo.

Of course some are NEW to 8.8.8 and won't be in my older running install.
phoenix
Ambassador
Ambassador
Posts: 25534
Joined: Fri Sep 12, 2014 9:56 pm

Re: upgrade from 8.8.6 to 8.8.8 using the tar ball and saying NO to use ZIMBRA Internet repos fails

Postby phoenix » Thu Jul 12, 2018 8:11 pm

ivanbishop wrote:To be clear I'd rather NOT be downloading tarballs and running a local install.
You don't have a choice as only some of the packages (and patches) are in the repos, you still need to download the ZCS install file and run that install.
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
User avatar
tonster
Zimbra Employee
Zimbra Employee
Posts: 297
Joined: Fri Feb 21, 2014 10:14 am
Location: Ypsilanti, MI
ZCS/ZD Version: Release 8.7.0_GA_1659.RHEL6_64_2016

Re: upgrade from 8.8.6 to 8.8.8 using the tar ball and saying NO to use ZIMBRA Internet repos fails

Postby tonster » Fri Jul 13, 2018 12:54 am

ivanbishop wrote:Thanks Tonster.

To be clear I'd rather NOT be downloading tarballs and running a local install.

I want to setup and use the zimbra repo directly.

So, may I ask you to
[1] post the CORRECT zimbra.repo file?
[2] show a yum repolist

The docs are incorrect as they reference a toplevel domain (.tld) rather than the zimbra repo.

Once I have that file I should be able to yum repolist and "what provides" and see ALL the .RPMs you ship from the repo.

Of course some are NEW to 8.8.8 and won't be in my older running install.


Again, this points to a misunderstanding of how this works for Zimbra. Currently, pretty much the only things that exist in our repo are third-party software packages (java, jetty, amavisd, postfix, etc). The rest are still only in the tarball, and you can ONLY do minor/major upgrades using the tarball. The ONLY thing (starting with 8.8.8 patching) that will work without using install.sh and the tarball is installing the patches.

I'm unsure what document you're referencing, but if you can point to it I can verify that it's correct. The repo file you posted looks right to me, and if it's the one automatically generated then it would certainly be correct. As far as running yum repolist and "what provides", you already can see ALL the .RPM's we ship from the repo, it's just not the list you're thinking it should be. Unfortunately, not everything has been migrated to the repo and we're still tethered to the tarball for minor/major upgrades.

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 4 guests