Upgrade from 8.6 to 8.8 - Error: memcached not enabled

Ask questions about your setup or get help installing ZCS server (ZD section below).
PHP-Friends
Posts: 5
Joined: Sat Mar 28, 2015 3:55 pm

Upgrade from 8.6 to 8.8 - Error: memcached not enabled

Postby PHP-Friends » Mon Jul 09, 2018 3:13 pm

Hi,

I am trying to upgrade a Zimbra installation running on Ubuntu 14.04 in order to migrate the upgraded installation to a newer host. The process fails with the following error message:

Code: Select all

root@mail: ~/zcs-NETWORK-8.8.8_GA_2009.UBUNTU14_64.20180322150747 # ./install.sh

Operations logged to /tmp/install.log.Gt4WZSzS
Checking for existing installation...
    zimbra-chat...NOT FOUND
    zimbra-drive...NOT FOUND
    zimbra-imapd...NOT FOUND
    zimbra-license-tools...NOT FOUND
    zimbra-license-extension...NOT FOUND
    zimbra-network-store...NOT FOUND
    zimbra-network-modules-ng...NOT FOUND
    zimbra-ldap...FOUND zimbra-ldap-8.6.0.GA.1153.UBUNTU14.64
    zimbra-logger...FOUND zimbra-logger-8.6.0.GA.1153.UBUNTU14.64
    zimbra-mta...FOUND zimbra-mta-8.6.0.GA.1153.UBUNTU14.64
    zimbra-dnscache...FOUND zimbra-dnscache-8.6.0.GA.1153.UBUNTU14.64
    zimbra-snmp...FOUND zimbra-snmp-8.6.0.GA.1153.UBUNTU14.64
    zimbra-store...FOUND zimbra-store-8.6.0.GA.1153.UBUNTU14.64
    zimbra-apache...FOUND zimbra-apache-8.6.0.GA.1153.UBUNTU14.64
    zimbra-spell...FOUND zimbra-spell-8.6.0.GA.1153.UBUNTU14.64
    zimbra-convertd...NOT FOUND
    zimbra-memcached...NOT FOUND
    zimbra-proxy...FOUND zimbra-proxy-8.6.0.GA.1153.UBUNTU14.64
    zimbra-archiving...NOT FOUND
    zimbra-core...FOUND zimbra-core-8.6.0.GA.1153.UBUNTU14.64
ZCS upgrade from 8.6.0 to 8.8.8 will be performed.
Checking for existing proxy service in your environment
Checking for existing memcached service in your environment
Error: memcached not enabled
Error: No memcached detected in your environment. Memcached is required for ZCS 8.7+.
See https://wiki.zimbra.com/wiki/Enabling_Zimbra_Memcached for details on installing memcached.
Proxy and Memcached services must exist. Exiting...


Of course I have checked the mentioned documentation (and searched Google for hours), but to be honest, I do not get it. The wiki entry and many blog articles etc. refer to run the install.sh and proceeding in the following way:

Code: Select all

Do you wish to upgrade? [Y] y
Install zimbra-memcached [N] y
Install zimbra-proxy [N] y


But, as you can see above, I am simply unable to get this far as the install.sh terminates with the described error message. I have tried several parameters regarding the installer, I tried the 8.7 version and even the same version (8.6 -> 8.6) in order to reach the point where I can install memcached. I even installed the zimbra memcached .deb package manually and tried to activate it as user "zimbra", but it does not recognize it:

Code: Select all

zimbra@mail:~$ memcached start
The program 'memcached' is currently not installed. To run 'memcached' please ask your administrator to install the package 'memcached'

zimbra@mail:~$ zmprov ms `zmhostname` +zimbraServiceEnabled memcached
ERROR: zclient.IO_ERROR (invoke sun.security.validator.ValidatorException: PKIX path validation failed: java.security.cert.CertPathValidatorException: timestamp check failed, server: localhost) (cause: javax.net.ssl.SSLHandshakeException sun.security.validator.ValidatorException: PKIX path validation failed: java.security.cert.CertPathValidatorException: timestamp check failed


Any help to find out what my mistake is would be greatly appreciated!

Best Regards,
Tim


phoenix
Ambassador
Ambassador
Posts: 25534
Joined: Fri Sep 12, 2014 9:56 pm

Re: Upgrade from 8.6 to 8.8 - Error: memcached not enabled

Postby phoenix » Mon Jul 09, 2018 3:42 pm

You are supposed to install memcached & proxy on your current installation then upgrade. If you want an easy method to move your current installation then you should move your current installation to a new ZCS 8.8.8 server using the ZeXtras modules, you don't need to upgrade before you do the move.
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
PHP-Friends
Posts: 5
Joined: Sat Mar 28, 2015 3:55 pm

Re: Upgrade from 8.6 to 8.8 - Error: memcached not enabled

Postby PHP-Friends » Mon Jul 09, 2018 3:47 pm

Hi,

thank you very much for the quick response! I will check ZeXtras, but however, how would I install the memcached in my current installation? Like I described it, that was what I tried (using the install.sh of my current version), but I was not successful following the wiki article in order to "add" memcached to the 8.6 installation :(

Best regards,
Tim
phoenix
Ambassador
Ambassador
Posts: 25534
Joined: Fri Sep 12, 2014 9:56 pm

Re: Upgrade from 8.6 to 8.8 - Error: memcached not enabled

Postby phoenix » Mon Jul 09, 2018 3:55 pm

Your log above shows that memcached is not installed on your current ZCS 8.6(?) while performing an upgrade to 8.8.8 but you haven't given any logs that show you have installed it on your 'old' version.

If you want to see if the services are install and enabled then run the following:

Code: Select all

zmprov gs $(zmhostname) zimbraServiceEnabled zimbraServiceInstalled


When you say you were 'not successful', what errors did you see when you tried to install memcached? Without that being installed I'm afraid you won't be upgrading any time soon unless you do the move to a new server.
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
PHP-Friends
Posts: 5
Joined: Sat Mar 28, 2015 3:55 pm

Re: Upgrade from 8.6 to 8.8 - Error: memcached not enabled

Postby PHP-Friends » Mon Jul 09, 2018 4:05 pm

I might be completely misunderstandig the wiki article, but regarding to this article it would be simply:

Start 8.5, or above, installer (install.sh script)


That is what I did (see the first post where I pasted my shell output from that try), however it seems to be wrong if I get you right. And as it does not offer me the "Install zimbra-memcached" question I am even more sure that I must have misunderstood the wiki article.

I have tried your the command you gave me:

Code: Select all

zimbra@mail:~$ zmprov gs $(zmhostname) zimbraServiceEnabled zimbraServiceInstalled
ERROR: zclient.IO_ERROR (invoke sun.security.validator.ValidatorException: PKIX path validation failed: java.security.cert.CertPathValidatorException: timestamp check failed, server: localhost) (cause: javax.net.ssl.SSLHandshakeException sun.security.validator.ValidatorException: PKIX path validation failed: java.security.cert.CertPathValidatorException: timestamp check failed


I think this is not related to memcached but another problem which might occure due to my last tries, I might have broken something :) I will do some research about this issue later this evening. Again, thank you very much!


Best Regards,
Tim
User avatar
L. Mark Stone
Elite member
Elite member
Posts: 1780
Joined: Wed Oct 09, 2013 11:35 am
Location: Portland, Maine
ZCS/ZD Version: 8.8.8 Patch 4 Network Edition
Contact:

Re: Upgrade from 8.6 to 8.8 - Error: memcached not enabled

Postby L. Mark Stone » Mon Jul 09, 2018 4:09 pm

PHP-Friends wrote:Hi,

thank you very much for the quick response! I will check ZeXtras, but however, how would I install the memcached in my current installation? Like I described it, that was what I tried (using the install.sh of my current version), but I was not successful following the wiki article in order to "add" memcached to the 8.6 installation :(

Best regards,
Tim


Tim,

You don't mention which wiki article you were trying to follow (see link below for the Certified one...), but as Phoenix has said, you must have proxy/memcached working on your existing installation before you upgrade. If your existing system is 8.6, then you need to rerun the Zimbra 8.6 installer - not the 8.8 installer - to get the 8.6 versions of proxy and memcached installed on your 8.6 system. Only then can you upgrade to 8.8.

That's why Phoenix again suggested that instead you build a fresh clean server on the latest operating system and use the ZeXtras Suite (Trial License) to perform the server-to-server migration, as this gives you a roll back option and doesn't risk damaging your existing system.

Hope that helps,
Mark

https://wiki.zimbra.com/wiki/Enabling_Z ... _memcached
_____________________________________
L. Mark Stone
Mission Critical Email - Zimbra VAR/BSP and Consulting https://www.missioncriticalemail.com/
Zeta Alliance http://www.zetalliance.org/
PHP-Friends
Posts: 5
Joined: Sat Mar 28, 2015 3:55 pm

Re: Upgrade from 8.6 to 8.8 - Error: memcached not enabled

Postby PHP-Friends » Mon Jul 09, 2018 4:16 pm

L. Mark Stone wrote:You don't mention which wiki article you were trying to follow (see link below for the Certified one...)

Sorry if this was not clear, of course I used the article linked in the error message I quoted - which is exactly the link you gave me :(

L. Mark Stone wrote:as Phoenix has said, you must have proxy/memcached working on your existing installation before you upgrade. If your existing system is 8.6, then you need to rerun the Zimbra 8.6 installer - not the 8.8 installer - to get the 8.6 versions of proxy and memcached installed on your 8.6 system. Only then can you upgrade to 8.8.

I got that, and I tried that, as described above. However, the installer fails before offering me the memcached installation.

Best Regards,
Tim

// However, I now definately know that using the install.sh of the current version is the right way. I will try to proceed with that later this evening and solve the errors which are shown currently (basically the same like in my previous post, I have a problem with SSL currently :)). Thank you very much!
User avatar
gabrieles
Posts: 28
Joined: Tue Feb 14, 2017 9:40 am

Re: Upgrade from 8.6 to 8.8 - Error: memcached not enabled

Postby gabrieles » Fri Jul 13, 2018 12:37 pm

Technically you don't need to have proxy and memcached installed on your starting server. It can be a simple mailstore in a multiserver environment.
The installer asks the ldap to see if in at least one of your machines resides a proxy service. You can fool him setting temporarily them installed and enabled with:

Code: Select all

zmprov ms $(zmhostname) zimbraServiceInstalled proxy zimbraServiceInstalled memcached zimbraServiceEnabled proxy zimbraServiceEnabled memcached

Your update will not stop and exit, but you have to pay great attention to the ports in the new environment: they will remain mapped to the mailbox like before, and need to be mapped correctly to use the new, and now required, proxy service.

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 9 guests