Redirects not going to correct port

Discuss your pilot or production implementation with other Zimbra admins or our engineers.
msmcknight
Advanced member
Advanced member
Posts: 96
Joined: Sat Sep 13, 2014 12:27 am

Redirects not going to correct port

Postby msmcknight » Sat Aug 11, 2018 6:39 am

Hi everyone,

I recently upgraded from 8.6 to 8.8.8 and as part of that upgrade, I had to start using the proxy. I'm guessing I have something misconfigured because...

When I am logged into the Admin GUI and click on View Mail for one of the users, the window that is opened to view the users mail is missing the TCP port number. For example, my server has a URL of https://zimbra.example.com:5000 , my admin server is at port 5571, but when I click to view a users mail, the URL that results is: https://zimbra.example.com (no port specified).

This same behavior happens if a user is logged into the regular zimbra web client and they right click on a calendar and select "Open in a separate window".... that separate window is missing the port number.

Without the port number, the browser fails to connect to zimbra in these new windows. I am also having a problem with zimbra drive.... when I try to use it, it says "failed to connect."

My guess is that somewhere during the upgrade and switch to use the proxy I messed something up and the port configuration is jacked up. I'm pretty new to zimbra and have absolutely no idea where to look for the appropriate configuration settings. If anyone out there can help, or even just point me in the right direction, it would be greatly appreciated.

Thanks to you all in advance,
-Michael


phoenix
Ambassador
Ambassador
Posts: 25722
Joined: Fri Sep 12, 2014 9:56 pm

Re: Redirects not going to correct port

Postby phoenix » Sat Aug 11, 2018 8:40 am

There is a wiki article that covers the installation of the proxy & memcached prior to an update, did you read that? If not (or even if you did), I'd suggest you check your config again with that article: https://wiki.zimbra.com/wiki/Enabling_Z ... _memcached
Regards

Bill

Rspamd: A high performance spamassassin replacement

If you'd like to see this implemented in a future version of ZCS then please vote on Bugzilla entries 97706 & 108168
msmcknight
Advanced member
Advanced member
Posts: 96
Joined: Sat Sep 13, 2014 12:27 am

Re: Redirects not going to correct port

Postby msmcknight » Sat Aug 11, 2018 3:45 pm

Yes, I followed those steps as part of the upgrade... at least I thought I had. Is there a way to display all current settings? If not, what would the commands be to display the settings that might be causing these symptoms?

Thank you,
-Michael
msmcknight
Advanced member
Advanced member
Posts: 96
Joined: Sat Sep 13, 2014 12:27 am

Re: Redirects not going to correct port

Postby msmcknight » Sat Oct 06, 2018 6:57 am

Hi everyone,

Does anyone have any ideas on how I can fix these issues? Right now, I can't even find a command that will display my current settings in order to see if a value is incorrect. Like, what is the mapping between the proxy and zimbra... ie proxy listens on port X and redirects to port Y for service zzzzz.

Any help would be appreciated.

Thank you,
-Michael
msmcknight
Advanced member
Advanced member
Posts: 96
Joined: Sat Sep 13, 2014 12:27 am

Re: Redirects not going to correct port

Postby msmcknight » Sat Oct 06, 2018 8:01 am

Hi everyone,

I think I figured it out. In the admin GUI under domains->general information, the Public service port was set to 443, but my server was listening on 5443. I don't know how I had it where the server would start-up and listen on 5443, but the public service port was set to something else.

How/where could I have gotten these two different settings and for most purposes, the server worked as expected? ie. Where is the setting that tells the server to listen on port 9443, and how could that have been set to something different than public service port?

Anyway, looks like it's working now.

Return to “Administrators”

Who is online

Users browsing this forum: No registered users and 24 guests