Reinstall of Zimbra NE 8.8.11 post Ubuntu 14.04 to 16.04 hangs on installing zco-patch

Ask questions about your setup or get help installing ZCS server (ZD section below).
kid
Posts: 1
Joined: Tue Jan 08, 2019 7:51 am

Reinstall of Zimbra NE 8.8.11 post Ubuntu 14.04 to 16.04 hangs on installing zco-patch

Postby kid » Tue Jan 08, 2019 8:20 am

Hi, all!

I have just mostly completed the following dance:

Ubuntu 12.04 w/Zimbra 8.6.0 -> Ubuntu 14.04 w/Zimbra 8.6.0 -> Ubuntu 14.04 w/Zimbra 8.8.11 -> Ubuntu 16.04 w/Zimbra 8.8.11 Patch 1


Based on https://wiki.zimbra.com/wiki/Ubuntu_Upgrades.

Most things went well but while reinstalling Zimbra 8.8.11 on Ubuntu 16.04 the installer stalled while installing zimbra-patch:

Code: Select all

~/zcs-NETWORK-8.8.11_GA_3737.UBUNTU16_64.20181207111719# ./install.sh -s

Installing extra packages (1):
   zimbra-patch


Tailing the log revealed that extraction of zco-patch.2019-01-04.zip was awaiting user input for handling file conflicts:

Code: Select all

preparing to unpack .../zimbra-zco_8.8.11.1.0.0.1546605159-1.u16_amd64.deb ...
***** Installing Zimbra-zco patch *****
Unpacking zimbra-zco (8.8.11.1.0.0.1546605159-1.u16) ...
Selecting previously unselected package zimbra-patch.
Preparing to unpack .../zimbra-patch_8.8.11.1546581876.p1-2.u16_amd64.deb ...
Unpacking zimbra-patch (8.8.11.1546581876.p1-2.u16) ...
Setting up zimbra-zco (8.8.11.1.0.0.1546605159-1.u16) ...
*** Configuring Zimbra-ZCO-patch ***
*** Extracting the ZCO patch ***
Archive:  zco-patch.2019-01-04.zip
replace User Instructions Connector for Outlook.pdf? [y]es, [n]o, [A]ll, [N]one, [r]ename:


Entering the required answers in the tmux session where the install script was running enabled the process to complete:

Code: Select all

replace User Instructions Connector for Outlook.pdf? [y]es, [n]o, [A]ll, [N]one, [r]ename: y
  inflating: User Instructions Connector for Outlook.pdf 
replace ZimbraConnectorOLK_8.8.11.1800_x64-UNSIGNED.msi? [y]es, [n]o, [A]ll, [N]one, [r]ename: y   
y
  inflating: ZimbraConnectorOLK_8.8.11.1800_x64-UNSIGNED.msi 
replace ZimbraConnectorOLK_8.8.11.1800_x64.msi? [y]es, [n]o, [A]ll, [N]one, [r]ename: y
  inflating: ZimbraConnectorOLK_8.8.11.1800_x64.msi 
replace ZimbraConnectorOLK_8.8.11.1800_x86-UNSIGNED.msi? [y]es, [n]o, [A]ll, [N]one, [r]ename: y
  inflating: ZimbraConnectorOLK_8.8.11.1800_x86-UNSIGNED.msi 
replace ZimbraConnectorOLK_8.8.11.1800_x86.msi? [y]es, [n]o, [A]ll, [N]one, [r]ename: y
  inflating: ZimbraConnectorOLK_8.8.11.1800_x86.msi 
replace ZmCustomizeMsi.js? [y]es, [n]o, [A]ll, [N]one, [r]ename: y
  inflating: ZmCustomizeMsi.js       
Removing /opt/zimbra/mailboxd/webapps/zimbra/downloads/ZimbraConnectorOLK_8.8.10.1788_x64.msi
Removing /opt/zimbra/mailboxd/webapps/zimbra/downloads/ZimbraConnectorOLK_8.8.10.1788_x86.msi
Removing /opt/zimbra/mailboxd/webapps/zimbra/downloads/ZimbraConnectorOLK_8.8.10.1788_x64-UNSIGNED.msi
Removing /opt/zimbra/mailboxd/webapps/zimbra/downloads/ZimbraConnectorOLK_8.8.10.1788_x86-UNSIGNED.msi
*** ZCO patch installed successfully **


I should go and file a bug report I think :)

--
Br,
kid


Phangorn
Posts: 2
Joined: Mon Apr 10, 2017 12:30 pm

Re: Reinstall of Zimbra NE 8.8.11 post Ubuntu 14.04 to 16.04 hangs on installing zco-patch

Postby Phangorn » Mon Mar 11, 2019 1:10 pm

Entering the required answers in the tmux session where the install script was running enabled the process to complete:


i'm stuck at this point,
how do you do to enter the answers to the process ?

Return to “Installation and Upgrade”

Who is online

Users browsing this forum: No registered users and 7 guests